Opened 2 years ago

Closed 2 years ago

#12091 closed defect (fixed)

OFW XO-4 - Can't boot with Q7A12 if bootfw.zip is on the disk

Reported by: wmb@… Owned by: Quozl
Priority: normal Milestone: Not Triaged
Component: ofw - open firmware Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: diagnose
Verified: no

Description

svn 3285 changed (fw-version) to use signature- offset instead of the hardcoded offset for locating the signature in the OFW image. The problem is that the signature is still at the old location for existing bootfw bundles for XO-1.75.

I think the solution is to make different bootfw names for different platforms.

Change History (3)

comment:1 Changed 2 years ago by wmb@…

I suggest bootfw4.zip for XO-4, and XO-4 should not even look at unadorned bootfw.zip . For our existing A2 boards, the check for bootfwN.zip should be skipped entirely, because we are about to change the ROM size and having to support both sizes in the verification is just going to cause complexity that will lead to bugs.

comment:2 Changed 2 years ago by Quozl

  • Owner changed from wmb@… to Quozl
  • Status changed from new to assigned

Reverted svn 3285 to ensure compatibility with current build.

comment:3 Changed 2 years ago by Quozl

  • Resolution set to fixed
  • Status changed from assigned to closed

Q7A13 includes the reversion. Further work on the original problem is in #12079.

Note: See TracTickets for help on using tickets.