Ticket #12096 (closed defect: fixed)

Opened 20 months ago

Last modified 17 months ago

XO-4 Q7A13 audio test impulse response flatlined with loopback cable

Reported by: Quozl Owned by: Quozl
Priority: blocker Milestone: 4-firmware
Component: ofw - open firmware Version: Development build as of this date
Keywords: Cc: Chia-Hsiu.Chang@…
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

The audio test fails both channels in loopback mode, with the impulse response plot showing a flat line on both channels.

Reproducer:

 ok select /audio 1 to plot?
 ok 5 to test-station diag-mode test /audio

The first and second impulse response curves are not flat.

Change History

Changed 19 months ago by chia-hsiu

duplicate with B-stage pre-build machine, OFW is Q7B01.
Fail rate is 50%, 10 of 20 times audio test.

Changed 19 months ago by chia-hsiu

I'm testing Q7B03 and find it still may get failure when using automatic method to test audio jacks(loopback cable). I feel it's sensitively. Headphone jack first then mic jack seems better.

Changed 18 months ago by Quozl

  • priority changed from normal to blocker
  • next_action changed from never set to diagnose
  • milestone set to 4-firmware

Changed 18 months ago by Quozl

Symptom still occurs with SVN head. The symptom is missing if the startup sound volume is set to zero.

Changed 18 months ago by Quozl

#12109 may relate.

Changed 18 months ago by chia-hsiu

My test result as below
1. when get-saved-volume is 0, 8/10 fail, 2/10 pass
2. when get-saved-volume is ffffffce, 2/10 fail, 8/10 pass

Changed 18 months ago by Quozl

  • next_action changed from diagnose to test in build
  • blockedby 12109 added

Please test again with http://dev.laptop.org/~quozl/q7b04jc.rom which is based on svn 3395. I've tested and the symptom no longer occurs.

Changed 18 months ago by chia-hsiu

I have tested with Q7B04jc, it looks good when test-station is 4 or 5. I set volume large and tried about 20 times, only one failure appear.
But the failure rate still high when test-station is 1 (SMT). SMT audio test need a special fixture, so please skip speaker test by below command, and help to check again, thanks.

select /audio[[BR]]
patch noop acoustic-test automatic-test[[BR]]
1 to test-station diag-mode[[BR]]
test /audio

Changed 18 months ago by Quozl

  • next_action changed from test in build to diagnose
  • blockedby 12109 removed

Thanks, I see failure too. My testing was too brief. Investigating.

Changed 18 months ago by chia-hsiu

I original think it may caused by different insert technique, but after continue test 10 times loopback without inserting loopback, it still have failure.
Test with svn head 3416.

dev /audio
patch noop acoustic-test automatic-test
patch noop connect-loopback loopback-test
patch noop disconnect-loopback loopback-test
dend
1 to test-station
diag-mode
test /audio

test 10 times manually.

Changed 18 months ago by wmb@…

Please test http://dev.laptop.org/~wmb/q7b05ma.rom

That version passed 100 times in a row.

I gave up on trying to make the Marvell hardware work correctly, and instead changed the test so that it passes if the channel data is in the wrong order in memory.

Here is a way to run the test repeatedly, after doing the patches in the previous comment:

  ok 0
  ok dup .d 1+  test /audio  many

It will run the test until you type a key.

In over 300 runs, I saw 2 instances of "Right channel failure". In previous versions, the failure rate was about 1 in 6.

Changed 18 months ago by chia-hsiu

Thanks! It's better than fail in production line.
I got three boards replaced with B1 version SoC(1Ghz & 1.2Ghz), the symptom is the same, failure rate is still high.
After flashing to q7b05ma, they all passed 100 times by previous cmd.

Changed 17 months ago by Quozl

  • status changed from new to closed
  • next_action changed from diagnose to no action
  • resolution set to fixed
Note: See TracTickets for help on using tickets.