Opened 2 years ago

Closed 2 years ago

#12116 closed defect (fixed)

Runin target not being run by systemd

Reported by: greenfeld Owned by: dsd
Priority: normal Milestone: 13.1.0
Component: manufacturing process Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description (last modified by greenfeld)

The runin-check service does not seem to be executed by systemd in 13.1.0 os2.

I set TS=RUNIN on a XO-1.75 and the first boot went all the way to Sugar. I touched /runin/force & soiled and that did not work either.

Executing /runin/runin-check by hand over the serial console did start runin.

There is no sign in the kmesg serial logs that runin-check is being run during boot and deciding not to do anything.

Change History (5)

comment:1 Changed 2 years ago by greenfeld

  • Description modified (diff)

comment:2 Changed 2 years ago by dsd

  • Milestone changed from Not Triaged to 13.1.0
  • Owner set to dsd

comment:3 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to add to build

Fixed in olpc-os-builder 2904925d37

comment:4 Changed 2 years ago by pbrobinson

  • Action Needed changed from add to build to test in build

Should be in os4

comment:5 Changed 2 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Runin starts via systemd in 13.1.0 os5.

Note: See TracTickets for help on using tickets.