Ticket #12120 (closed defect: fixed)

Opened 23 months ago

Last modified 22 months ago

Bring back GNOME-2 style desktop

Reported by: martin.langhoff Owned by: dsd
Priority: normal Milestone: 13.1.0
Component: distro Version: Software Build 12.1.0-21
Keywords: Cc: dsd, tonyforster, sridhar
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

We have feedback on 12.1.0 that GNOME desktop seems to have regressed in functionality, both in private discussions and in open tickets (#12118).

Essentially, we want to have Nautilus manage the desktop.

Change History

Changed 23 months ago by martin.langhoff

  • cc dsd added
  • owner changed from pbrobinson to martin.langhoff

Initial exploration: I can see (in gnome-tweak-tool src) that we need to add entries to autostart nautilus. But after using gnome-tweak-tool on an XO successfully, I cannot find the configuration on-disk where I expect it to be (~/.config).

Changed 23 months ago by greenfeld

Are we planning to create a hybrid version of GNOME 3, or do we want to take MATE (GNOME 2 fork) if it lands in F18 (http://fedoraproject.org/wiki/Features/MATE-Desktop)?

Changed 23 months ago by martin.langhoff

  • owner changed from martin.langhoff to dsd

What we are essentially after is to bring back the nautilus-managed desktop. Rationale:

  • Users are used to the Desktop-is-a-directory metaphor that is in use in all other Desktop UIs since Mac OS started it. Removal of desktop-is-a-directory is a regression.
  • We have a major usability regression from 11.x.y and earlier with the loss of "Switch to Sugar".

When I install gnome-tweak-tool and run it, and enable the "nautilus manages desktop" option, I get the desired changes.

Changed 23 months ago by tonyforster

  • cc tonyforster added

OS3, Not sure if these 'regressions' belong in this ticket: *double clicking a py file no longer executes it, important for gnomised activities like turtleart *I am unable to set my location or the time

Changed 22 months ago by dsd

Switch to Sugar is still available from the GNOME menu.

The other side of the discussion here is that the desktop duplicates functionality of other parts of the system without really adding anything, and I have seen it cause confusion in the field - why do you have to double click the icons? why do you have to hide your work to get to it? I didn't like the change at first when it got introduced on my own desktop, but after some time I got used to it and would argue in favour of removing it.

Anyway, I'll assume that these requests come based on experience with real users (children) so if there are no objections I'll go forward and reinstate the nautilus-driven desktop it within a couple of days.

Changed 22 months ago by dsd

  • next_action changed from never set to add to build

Fixed in olpc-utils-3.0.4.

Changed 22 months ago by sridhar

  • cc sridhar added

Changed 22 months ago by dsd

  • next_action changed from add to build to test in build

Test in 13.1.0 build 6

Changed 22 months ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

The icon-usable desktop is back in 13.1.0 os6.

Note: See TracTickets for help on using tickets.