Ticket #12135 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

XO-4 B1 fails to boot

Reported by: wad Owned by: wad
Priority: high Milestone: Not Triaged
Component: ofw - open firmware Version: 4-B1
Keywords: XO-4 B1 Cc:
Action Needed: reproduce Verified: no
Deployments affected: Blocked By:
Blocking:

Description

When an XO-4 B1 has been sitting unpowered for a long period of time, it sometimes doesn't boot. The visible symptom is that the screen powers on, but there is no boot chime and there is no XO icon drawn on the screen.

This is difficult to reproduce, as it always seems to boot fine the second time. I mainly discovered this when booting laptops from the factory for the first time.

The message printed on the serial port is the CForth banner through "releasing", then "Unimplemented package interface procedure". CForth eventually decides that OFW didn't start up and prints a 52 ("OFW seems not to have booted all the way").

Change History

Changed 2 years ago by wmb@…

I saw it too on my B1, this morning.

Changed 2 years ago by wad

  • owner changed from wmb@… to wad

Seen on both SKU292 and SKU294 laptops. Mitch's is either a SKU291/SKU293, so this appears on all hardware versions.

Changed 2 years ago by martin.langhoff

Just seen it on SKU 292 SHC2380002A.

Changed 2 years ago by wmb@…

Fixed, I think, by svn 3353

Changed 2 years ago by wad

  • status changed from new to closed
  • resolution set to fixed

Fix verified.

The problem was that the efface-md function was being called on first boot out of the factory, and it was trying to power-cycle the DCON before the DCON device was instantiated, hence the "Unimplemented package interface method" which was really a call to dcon-off.

Note: See TracTickets for help on using tickets.