Opened 2 years ago

Closed 2 years ago

#12181 closed defect (fixed)

Secure boot fails to load initramfs on XO-4

Reported by: dsd Owned by: wmb@…
Priority: normal Milestone: 4-firmware
Component: ofw - open firmware Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: add to release
Verified: no

Description

13.1.0 build 5 includes the initramfs both unzipped, and zipped (but unsigned) in runrd.zip. Similar story for the kernel. http://build.laptop.org/13.1.0/os5/xo-4/31005o4.zd

However, booting from the zip files isn't working - the kernel doesn't boot the initramfs.

To test:

false to require-signatures?
" \boot" pn-buf place
" int:" load-from-list

The firmware does seem to find the initramfs ("RD found -"), but the kernel crashes early during boot.

RAMDISK: gzip image found at block 0
...
No filesystem could mount, tried: ...
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

Change History (2)

comment:1 Changed 2 years ago by wmb@…

  • Action Needed changed from never set to add to release

This appears to be related to #12106, per this message which is the first difference in the kernel logs between the working and non-working cases:

[ 0.311622] rootfs image is not initramfs (compression method gzip not configured); looks like an initrd

--- Indeed, that is what is happening.

Fixed by svn 3366

comment:2 Changed 2 years ago by wmb@…

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.