Ticket #12181 (closed defect: fixed)

Opened 18 months ago

Last modified 17 months ago

Secure boot fails to load initramfs on XO-4

Reported by: dsd Owned by: wmb@…
Priority: normal Milestone: 4-firmware
Component: ofw - open firmware Version: not specified
Keywords: Cc:
Action Needed: add to release Verified: no
Deployments affected: Blocked By:
Blocking:

Description

13.1.0 build 5 includes the initramfs both unzipped, and zipped (but unsigned) in runrd.zip. Similar story for the kernel. http://build.laptop.org/13.1.0/os5/xo-4/31005o4.zd

However, booting from the zip files isn't working - the kernel doesn't boot the initramfs.

To test:

false to require-signatures?
" \boot" pn-buf place
" int:" load-from-list

The firmware does seem to find the initramfs ("RD found -"), but the kernel crashes early during boot.

RAMDISK: gzip image found at block 0
...
No filesystem could mount, tried: ...
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

Change History

Changed 18 months ago by wmb@…

  • next_action changed from never set to add to release

This appears to be related to #12106, per this message which is the first difference in the kernel logs between the working and non-working cases:

[ 0.311622] rootfs image is not initramfs (compression method gzip not configured); looks like an initrd

--- Indeed, that is what is happening.

Fixed by svn 3366

Changed 17 months ago by wmb@…

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.