Opened 2 years ago

Closed 22 months ago

#12199 closed defect (fixed)

XO-1.75 recorded audio is complete gibberish in os6

Reported by: greenfeld Owned by: dsd
Priority: high Milestone: 13.1.0
Component: kernel Version: not specified
Keywords: Cc: jnettlet
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

XO-1.75 recorded audio is complete gibberish in os6. One may also hear wierd noises out of the speakers when starting/ending the recording process in the Record activity.

This is a regression to the 20120926.1806.olpc.6d0e853 kernel included with os5. Installing this kernel on os6 makes the recorded audio intelligible again (but not perfect).

Change History (6)

comment:1 Changed 2 years ago by dsd

  • Cc dsd removed
  • Owner set to dsd
  • Status changed from new to assigned

comment:2 Changed 2 years ago by dsd

Reverting commit f9d35acbe063de67747826ddba2bcaa692757e1b. (enable cache speedup) does not help. Needs a bit more investigation.

comment:3 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to add to build

We were close. The commit that introduces the regression is a8137cd10a1ab06650a337c85b001cb4dba3a56d "ARM: pxa: append options of tauros2 L2 controller"

It even introduces the regression before we've explicitly turned it on on the .config (f9d35acbe063de67747826ddba2bcaa692757e1b).

Reverted those 2 commits for the time being, because I know Jon has other priorities. We could consider a fix for this (that doesn't involve reverting the speedup) if it arrives within the current release milestone, i.e. before Nov 15th.

comment:4 Changed 2 years ago by dsd

  • Action Needed changed from add to build to test in build

Fixed in 13.1.0 build 10.

comment:5 Changed 2 years ago by dsd

  • Cc jnettlet added

comment:6 Changed 22 months ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from assigned to closed

XO-1.75 audio recording works & sounds like it did before in 13.1.0 os20.

Note: See TracTickets for help on using tickets.