Opened 2 years ago

Closed 7 weeks ago

#12297 closed enhancement (fixed)

add dual-core

Reported by: cjb Owned by: Quozl
Priority: normal Milestone: 14.1.0
Component: kernel Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking: #12836
Deployments affected: Action Needed: no action
Verified: no

Description (last modified by Quozl)

XO-4 SMP must be factory-testable, to verify SoC and thermal design, and for performance.

Change History (24)

comment:1 Changed 2 years ago by shep

  • Cc shep@… added

comment:2 Changed 2 years ago by dsd

  • Cc dsd added
  • Priority changed from normal to blocker

While we won't enable SMP for the user at this time, SMP must be testable under either Linux or OFW for XO-4 production.

comment:3 Changed 2 years ago by dsd

  • Summary changed from SMP support for XO-4 to XO-4 SMP must be factory-testable

comment:4 Changed 2 years ago by dsd

  • Cc wad added

Actually, we're not 100% sure about what I wrote above. Wad, can you confirm if testable SMP is a factory requirement for XO-4 ramp?

comment:5 Changed 2 years ago by dsd

  • Priority changed from blocker to normal

In discussion with wad and Martin: While being able to test SMP is obviously desirable, this would be a big task, and SMP testability is not seen as a production requirement at this time.

comment:6 Changed 11 months ago by Quozl

  • Cc shep@… dsd wad removed
  • Milestone changed from 4-software to 13.2.0-android

comment:7 Changed 4 months ago by Quozl

  • Action Needed changed from never set to code
  • Milestone changed from 13.2.0-android to 14.1.0
  • Type changed from defect to enhancement
  • Version changed from not specified to Development build as of this date

comment:8 Changed 4 months ago by Quozl

  • Blocking 12836 added

comment:9 Changed 4 months ago by Quozl

  • Blocking 12835 added

(In #12835) add dependencies:

  • for factory testing of two critical new features, on #12834 (opengl), #12297 (dual-core),
Last edited 4 months ago by Quozl (previous) (diff)

comment:10 Changed 4 months ago by Quozl

  • Description modified (diff)
  • Owner changed from dilinger to Quozl
  • Summary changed from XO-4 SMP must be factory-testable to add dual-core

comment:11 Changed 3 months ago by Quozl

  • Blocking 12835 removed

comment:12 Changed 2 months ago by Quozl

  • Action Needed changed from code to diagnose

Today's a8394e7 is a working kernel, demonstrates dual core with build 5, but has several unrelated regressions including embedded controller communications, and discovery race of touchpad or touchscreen. These will be investigated next.

Also, Open Firmware will need a new release for device tree and register initialisation changes.

comment:13 Changed 2 months ago by Quozl

comment:14 Changed 2 months ago by Quozl

  • Action Needed changed from diagnose to add to build

comment:15 Changed 2 months ago by Quozl

  • Action Needed changed from add to build to test in build
  • is in build 6

comment:16 Changed 2 months ago by Quozl

comment:17 Changed 2 months ago by Quozl

  • fixes in previous comment have been packaged in kernel rpm ed9358b,

comment:18 Changed 2 months ago by Quozl

  • tested on Fedora 18 build 15 of 13.2.2 and Fedora 20 internal build 6.

comment:19 Changed 8 weeks ago by Quozl

  • a confusion of the embedded controller driver as a result of loss of one in a thousand interrupts was determined to be already present in 13.2.2,
  • further olpc-ec-1.75 driver fixes made to prevent loss of interrupts,
  • built kernel rpm b5935ad,
  • released firmware q7c01,

comment:20 Changed 8 weeks ago by Quozl

  • Action Needed changed from test in build to diagnose
  • VXCO_EN is not deasserting on suspend, because the second core is not powered down,
  • consequently, embedded controller is not indicating suspend using flashing power LED,

comment:21 Changed 7 weeks ago by Quozl

  • Action Needed changed from diagnose to add to build
  • VXCO_EN assert fixed,
  • built kernel rpm b2c8f99
  • tested power draw in suspend, against old kernel, no regression,

comment:22 Changed 7 weeks ago by Quozl

  • CPU interrupt affinity tuning required.

comment:23 Changed 7 weeks ago by Quozl

comment:24 Changed 7 weeks ago by Quozl

  • Action Needed changed from add to build to no action
  • Resolution set to fixed
  • Status changed from new to closed
  • package irqbalance added,
  • feature complete in build 7.
Note: See TracTickets for help on using tickets.