Ticket #1243 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Frame toggleable in Home mode after closing activity

Reported by: gabaug Owned by: marco
Priority: low Milestone: Trial-3
Component: distro Version:
Keywords: frames Cc: gabriel.burt@…
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

When you are in Home mode, you cannot toggle the frame, except immediately after closing an activity.

This happens in build 368 and latest sugar-jhbuild.

Attachments

olpc_frame.patch (370 bytes) - added by gabaug 7 years ago.
Sorry, pasting patches inline is apparently a bad idea.

Change History

  Changed 7 years ago by gabaug

Patch to fix the problem:

diff --git a/shell/view/frame/frame.py b/shell/view/frame/frame.py index fdff99c..9e362f6 100644 --- a/shell/view/frame/frame.py +++ b/shell/view/frame/frame.py @@ -184,6 +184,7 @@ class Frame(object):

def show(self):

if self.visible:

+ self.mode = MODE_FORCE

return

if self._animator:

self._animator.stop()

Changed 7 years ago by gabaug

Sorry, pasting patches inline is apparently a bad idea.

follow-up: ↓ 5   Changed 7 years ago by bert

I'd think this is by design - what else would you do in the home view except for using the frame?

  Changed 7 years ago by marco

  • priority changed from normal to low

It's by design. We might allow to hide the frame anyway (but don't remember the state when switching between views). That might feel better if you try to hide the frame on home for some reason. I'm not sure.

  Changed 7 years ago by marco

  • milestone changed from Untriaged to BTest-3

in reply to: ↑ 2   Changed 7 years ago by gabaug

Replying to bert:

I'd think this is by design - what else would you do in the home view except for using the frame?

Yes, the not being able to toggle the frame when in Home is by design. The bug is: after closing an activity, you *can* toggle it.

  Changed 7 years ago by gabaug

  • cc gabriel.burt@… added

  Changed 7 years ago by jg

  • owner changed from blizzard to marco
  • verified unset

  Changed 7 years ago by kimquirk

  • milestone changed from BTest-4 to Trial-2

moved to next sw release.

  Changed 7 years ago by jfuhrer

  • keywords frames added

I played around with this extensively while looking at a related ticket. I'm pretty much positive at this point that it is not closing an activity that causes the Frame to be togglable. In older builds, you could close by clicking a button in the frame that was next to the Neighborhoods/Groups/Home/Activities buttons. However, I think it is the case that what causes the bug is your cursor being over the frame when you switch to Home from a different mode (like Neighborhoods/Groups/Activities), and only if the frame was opened by mousing into a corner (NOT if it was opened via the frame toggle button). I have no problems with the frames toggling in Home if I quit using the activity's X button, or by using alt-C, UNLESS my cursor happened to be in the frame area when I pressed alt-C. (My cursor can't be in the frame area when pressing the X button, because the frame obscures the X button).

Here are a bunch of tests to run to show the different situations.

A) 1. Go to a non-Home area (like Neighborhood, Groups, Activity, etc.) 2. Open Frames by mousing to a corner. 3. With your cursor in the frame area, press the Home button on the keyboard (F3). 4. The frames will stay, but disappear once you mouse of them (unlocked). The Frame Toggle key will work normally.

B) 1. Go to a non-Home area (like Neighborhood, Groups, Activity, etc.) 2. Don't open Frames. Keep your mouse in the center. 3. Press the Home button on the keyboard (F3). 4. The frames will appear, locked, and the Frame Toggle key does not work.

C) 1. Go to a non-Home area (like Neighborhood, Groups, Activity, etc.) 2. Open Frames by mousing over to a corner. 3. Switch to Home by pressing the Home button at the top of the frame. (Cursor is within frame area.) 4. The Frames will disappear and be toggleable normally.

D) 1. Go to a non-Home area (like Neighborhood, Groups, Activity, etc.) 2. Open Frames by using the Frame Toggle key. It doesn't matter where your cursor is. 3. Press the Home button on the keyboard(F3). 4. The frames will appear, locked, but the Frame Toggle key can toggle them.

E) 1. Go to an Activity. 2. Open Frames by mousing over to a corner. 3. Quit the activity by pressing alt-C. 4. The frames will stay, but they will disappear as soon as you mouse off them and can be toggled normally.

F) 1. Go to an Activity. 2. Close the activity by clicking the activity's X button in the upper right-hand corner. 3. You will return to Home with the frames locked, and the Frame Toggle key cannot toggle them.

G) 1. Go to an Activity. 2. Open Frames with the Frame Toggle key. 3. Close the activity with alt-C (it doesn't matter whether or not your cursor is on the frame). 4. You will return to Home with the frames locked, but the Frame Toggle key can toggle them.

In conclusion, it seems like when you switch to Home while the cursor is over a Frame that was opened by mousing to it, then Frames become toggleable in Home via both mousing and the Frame Toggle key. If you switch to Home when the cursor is not over a frame, then the Frame becomes locked and the Frame Toggle key doesn't work. If you switch to Home when Frames are open that you have opened with the Frame Toggle key, then regardless of whether or not your mouse is over them, Frames will be locked and but Frame Toggle key still works.

  Changed 7 years ago by marco

  • milestone changed from Trial-2 to Trial-3

in reply to: ↑ description   Changed 7 years ago by gabaug

  • status changed from new to closed
  • resolution set to fixed

I tried to reproduce this on one of J5's XO's yesterday and could not reproduce it.

Note: See TracTickets for help on using tickets.