Opened 23 months ago

Closed 21 months ago

Last modified 20 months ago

#12536 closed defect (fixed)

XO-4 graphics corruption in Welcome screen

Reported by: dsd Owned by: jnettlet
Priority: high Milestone: 13.2.0
Component: x window system Version: not specified
Keywords: Cc: dsd, manuq
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

As of 13.1.0 build 28 for XO-4 (new graphics driver), general graphics corruption can be seen in some situations. The easy reproducer is just letting the welcome screen run on first boot. Leave it for a few minutes, you will soon reach a point where a small amount of graphics corruption can be visible in most of the frames.

Change History (3)

comment:1 Changed 23 months ago by dsd

Possibly related, these kernel messages also repeat while the welcome activity is running:

[   76.122554] gckOS_MapUserMemory(7176): error: info is freed.
[   76.128200] gcmkONERROR: status=-16(gcvSTATUS_OUT_OF_RESOURCES) @ gckKERNEL_Dispatch(1379)
[   76.138529] gcmkONERROR: status=-16(gcvSTATUS_OUT_OF_RESOURCES) @ gckOS_MapUserMemory(6994)
[   76.147168] gckOS_MapUserMemory(7134): error occured: -16.
[   76.153777] gckOS_MapUserMemory(7176): error: info is freed.
[   76.159405] gcmkONERROR: status=-16(gcvSTATUS_OUT_OF_RESOURCES) @ gckKERNEL_Dispatch(1379)
[   76.170570] gcmkONERROR: status=-16(gcvSTATUS_OUT_OF_RESOURCES) @ gckOS_MapUserMemory(6994)
[   76.178904] gckOS_MapUserMemory(7134): error occured: -16.
[   76.188158] gckOS_MapUserMemory(7176): error: info is freed.

comment:2 Changed 21 months ago by dsd

  • Cc manuq added
  • Milestone changed from 13.1.0 to 13.2.0
  • Resolution set to fixed
  • Status changed from new to closed

Can't reproduce on 13.2.0 build 3. Not sure what fixed this though, it definitely did happen before. manuq, please verify as well.

comment:3 Changed 20 months ago by manuq

I too can't reproduce it on build 3. I remember this happening before. Now in a new reflash of XO4 I kept the Welcome activity running for several minutes and there wasn't any graphics glitches.

Note: See TracTickets for help on using tickets.