#12549 closed defect (fixed)

eToys cannot record audio on XO-4

Reported by: greenfeld Owned by: bert
Priority: normal Milestone: 13.2.0
Component: etoys-activity Version: Development build as of this date
Keywords: Cc: dsd
Blocked By: #12671 Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

  1. Start eToys on a XO-4 in 13.1.0 os29.
  2. Using the touchpad, click "Make a new project".
  3. Click on "Supplies" (Open Chest with the double arrow).
  4. Click on "Sound Recorder".
  5. Drag the recorder to the canvas and click once to put it into place.
  6. Click on "Record" and make some noise. The sound meter will not move, or if it does move it does not move much.
  7. Click on "Stop".
  8. Click on "Play". Nothing will be heard.

There is also the possibility with step #8 that eToys may claim the recording is corrupt; but I could not reproduce this again while writing this ticket.

This is potentially related to Scratch's current inability to record (#12498) as eToys also uses Squeak.

Change History (6)

comment:1 Changed 19 months ago by dsd

  • Action Needed changed from diagnose to review
  • Milestone changed from Not Triaged to 13.2.0

comment:2 Changed 19 months ago by dsd

  • Blocking 12343 added

(In #12343) With the patch from #12549, etoys is working. Tested sound recording and playback on XO-1.5, XO-1.75 and XO-4.

With the squeak-vm patches from #12400, Scratch-24 is working. Tested sound recording, playback and camera usage on XO-1.5, XO-1.75 and XO-4.

I will add Scratch-24 to the next build, then we will wait on the closure of those 2 tickets.

Unfortunately the new Scratch version is 10mb bigger than the last one due to more files in the Media directory.

comment:3 Changed 18 months ago by dsd

  • Action Needed changed from review to add to build

Fixed in etoys-5.0.2408-5.fc18

comment:4 Changed 18 months ago by dsd

  • Action Needed changed from add to build to test in build

Test in 13.2.0 build 5

comment:5 Changed 18 months ago by dsd

  • Blocked By 12671 added
  • Blocking 12343 removed

I think this is working, but it can't be tested accurately in the presence of a new regression #12671.

comment:6 Changed 17 months ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Tested 13.2.0 build 7 on XO-4, sound recording work in etoys

Note: See TracTickets for help on using tickets.