Ticket #12564 (closed defect: fixed)

Opened 20 months ago

Last modified 20 months ago

[CL4] Can’t boot machine after run “memetest” in OFW.

Reported by: tomyin Owned by: Quozl
Priority: low Milestone: 4-firmware
Component: ofw - open firmware Version: not specified
Keywords: Cc:
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description (last modified by Quozl) (diff)

OS: 31030o4 OFW: Q7B16 EC: 0.3.12

Procedure:

  • Input “memtest” in OFW.
  • Press esc key to stop “memtest” after it run several cycle.
  • Input “boot” to boot machine. It shows “Scan for: OLPCOFW failed”.

Attachments

boot failed.jpg Download (0.9 MB) - added by tomyin 20 months ago.
boot failed

Change History

Changed 20 months ago by tomyin

boot failed

Changed 20 months ago by Quozl

  • status changed from new to assigned
  • next_action changed from never set to add to release
  • description modified (diff)
  • component changed from not assigned to ofw - open firmware
  • milestone changed from Not Triaged to 4-firmware
  • owner set to Quozl

Thanks. Reformatted ticket description to meet trac coventions, improving readability.

Reproduced symptom.

Diagnosis: this is due to diag-switch? being left set after memtest is stopped. When diag-switch? is set, the default boot is via network. The default network name is OLPCOFW.

Fixed in  svn 3564 by saving and restoring the value.

Test build:  http://dev.laptop.org/~quozl/q7b16jc.rom

Test case:

  • type memtest, press enter,
  • press enter once more so that only one cycle of test is run,
  • once the test has completed, try to boot, the expected result is to boot into Linux.

Will be in next release.

Changed 20 months ago by Quozl

  • status changed from assigned to closed
  • next_action changed from add to release to no action
  • resolution set to fixed

Is in Q7B17.

Note: See TracTickets for help on using tickets.