Opened 21 months ago

Closed 19 months ago

Last modified 19 months ago

#12572 closed defect (fixed)

"Alt +1" screenshots are partially blackened on XO-4 on build 30

Reported by: ajay_garg Owned by: jnettlet
Priority: high Milestone: 13.2.0
Component: x window system Version: not specified
Keywords: Cc: ajay_garg, dsd, manuq
Blocked By: Blocking:
Deployments affected: Australia Action Needed: diagnose
Verified: no

Description

Please see the attached screenshot of the 'blackened' screenshot.

Other notes ::
=============

a)
Things worked fine on build 21 for XO-4.

b)
Things always work fine for other platforms (tested on XO-1.75) for build 21 AND build 30.

c)
If xorg-x11-drv-dove is upgraded from 0.3.5-7 to 0.3.5-8 on build 21 of XO-4, the issue starts happening on build 21 too.

d)
If xorg-x11-drv-dove is downgraded from 0.3.5-8 to 0.3.5-7 on build 30 of XO-4, sugar fails to boot.

All in all, xorg-x11-drv-dove (version 8) is the culprit; however, downgrading it to version-7 causes the XO-4 to do not boot.

Attachments (2)

Screenshot of Home.png (26.2 KB) - added by ajay_garg 21 months ago.
screen.py (516 bytes) - added by ajay_garg 21 months ago.

Download all attachments as: .zip

Change History (7)

Changed 21 months ago by ajay_garg

comment:1 Changed 21 months ago by dsd

  • Action Needed changed from never set to diagnose
  • Cc dsd manuq added
  • Component changed from not assigned to x window system
  • Milestone changed from Not Triaged to 13.1.0
  • Owner set to jnettlet
  • Priority changed from normal to high

I think it would be useful to Jon to know exactly how these screenshots are taken (i.e. can you produce a simple command-line app that takes a screenshot the same way that sugar does?).

Can the import command from imagemagick successfully take screenshots?

Manuel, could you help us investigate here?

comment:2 Changed 21 months ago by ajay_garg

Attaching a simple "screen.py" python file, taking up the exact code from "extensions/globalkey/screenshot.py".

Changed 21 months ago by ajay_garg

comment:3 Changed 20 months ago by sridhar

  • Deployments affected set to Australia

comment:4 Changed 19 months ago by dsd

  • Milestone changed from 13.1.0 to 13.2.0
  • Resolution set to fixed
  • Status changed from new to closed

Can't reproduce this on 13.2.0 build 3. Not sure what fixed this though, it definitely did happen before. manuq, please verify as well.

comment:5 Changed 19 months ago by manuq

Can't reproduce anymore as well. I was adding screenshots taken with alt - f1 to attach them to SL tickets and none was corrupted with black areas.

Note: See TracTickets for help on using tickets.