Opened 4 years ago

Closed 4 years ago

#12651 closed defect (fixed)

Music keyboard sounds bad on XO-4 as of 13.2.0 build 3

Reported by: dsd Owned by: godiard
Priority: normal Milestone: 13.2.0
Component: tamtam-activity Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

German in Nicaragua noted that Music Keyboard sounds fine on 13.2.0 build 2, but sounds bad on 13.2.0 build 3. Testing XO-4 B1/C1. The sound is crackly.

Change History (5)

comment:1 Changed 4 years ago by dsd

  • Cc godiard removed
  • Component changed from kernel to tamtam-activity
  • Owner changed from dsd to godiard

As noted by others, this affects all the TamTam stuff. It is caused by the dmix configuration change from 44100Hz to 48000Hz.

Making that configuration change was effectively reverting the fix for #9414, but it was done with good reason (#12498).

Time to fix #9414 properly. It is a tamtam issue, doing its own sound resampling (badly). I will post a patch tomorrow.

comment:2 Changed 4 years ago by dsd

  • Action Needed changed from never set to review

comment:3 Changed 4 years ago by dsd

  • Action Needed changed from review to add to build

Fixed in MusicKeyboard-7 and TamTam*-67

comment:4 Changed 4 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 13.2.0 build 6.

comment:5 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Tested 13.2.0 build 7 on XO-4, sound quality is OK in TamTamMini and Music Keyboard.

Note: See TracTickets for help on using tickets.