Opened 4 years ago

Closed 4 years ago

#12658 closed defect (fixed)

GNOME hangs on XO-4 13.2.0 build 4

Reported by: erikos Owned by: dsd
Priority: normal Milestone: 13.2.0
Component: x window system Version: Development build as of this date
Keywords: Cc: greenfeld
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

Tested with os4 from 13.2.0

When you do "emacs .sugar/debug" (yum install emacs) the rendering of emacs takes ages (minutes), a close button is missing completely, the UI gets stalled, I have the impression that I have to move the mouse to keep on drawing the UI, after disabling PM the UI is updated without user interaction but still slow and at the end I do even get the close button, on os4 on an XO 1.5 things do work fine.

http://lists.laptop.org/pipermail/testing/2013-April/003001.html

http://bugs.sugarlabs.org/ticket/4489

Attachments (2)

os3-os4-diff.txt (13.2 KB) - added by erikos 4 years ago.
os3 - os4 package diff
Xorg.0.log (56.2 KB) - added by dsd 4 years ago.
Xorg log from when this happens, many errors

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by erikos

I happened to have an XO-4 with os2 (13.2.0) around and there Emacs renders fine. So there might have been a change in between that is causing this.

comment:2 follow-up: Changed 4 years ago by dsd

  • Summary changed from Emcas is not rendering on XO-4 to Emacs is not rendering on XO-4

I don't see myself having time to look into this at the moment. It would be interesting to know if it reproduces on 13.2.0 build 3.

If it doesn't happen on build 3, try "yum update xorg-x11-server", to determine if the X update in build 4 is the cause of this.

comment:3 Changed 4 years ago by wad

Emacs worked on os3 as well, in both Gnome and Sugar Terminal.

comment:4 in reply to: ↑ 2 Changed 4 years ago by dsd

Replying to dsd:

I don't see myself having time to look into this at the moment. It would be interesting to know if it reproduces on 13.2.0 build 3.

If it doesn't happen on build 3, try "yum update xorg-x11-server", to determine if the X update in build 4 is the cause of this.

This test is no longer valid because I pushed another X update.

Still guessing that this is related to the X update, it would be interesting to flash build 3 and upgrade from xorg-x11-server-Xorg-1.13.3-1.fc18.olpc2 to xorg-x11-server-Xorg-1.13.3-1.fc18.olpc3. See if the problem is introduced by this package update.

Alternatively, a slightly weaker test would be to upgrade build 4 from xorg-x11-server-Xorg-1.13.3-1.fc18.olpc3 to xorg-x11-server-Xorg-1.13.3-1.fc18.olpc4 and see if the problem goes away.

RPMs are at http://rpmdropbox.laptop.org/f18/

comment:5 Changed 4 years ago by dsd

  • Cc greenfeld added; dsd removed
  • Summary changed from Emacs is not rendering on XO-4 to GNOME hangs on XO-4 13.2.0 build 4

Sam pointed out yesterday that GNOME hangs on startup on this build as well, in a similar fashion. Must be the same issue. If anyone has time to upgrade packages on build 3 to the versions shipped in build 4, to narrow down what has caused this, it would be appreciated.

comment:6 Changed 4 years ago by erikos

  • I flashed an XO-4 with build 3
  • xorg-x11-server-Xorg-1.13.3-1.fc18.olpc2: emacs works and GNOME as well
  • update to xorg-x11-server-Xorg-1.13.3-1.fc18.olpc3: emacs works and GNOME as well
  • update to xorg-x11-server-Xorg-1.13.3-1.fc18.olpc4: emacs works and GNOME as well
  • I flashed an XO-4 with build 4
  • xorg-x11-server-Xorg-1.13.3-1.fc18.olpc4: emacs has the issues described in this ticket, I switched to GNOME and tried to start epiphany and rendering was not working similar to the emacs issue (works in os3 with the xorg updates to version olpc4)

Changed 4 years ago by erikos

os3 - os4 package diff

comment:7 Changed 4 years ago by erikos

Looking at the diff I glanced another xorg-package update: updating to xorg-x11-drv-dove-0.3.6-1.fc18.xo4.armv7hl.rpm on the os3 machine I can now reproduce the issue on this machine as well.

Looks like the xorg-x11-drv-dove update did introduce the issue.

comment:8 Changed 4 years ago by erikos

Anything to do with the fix in http://dev.laptop.org/ticket/12542#comment:13 maybe?

Changed 4 years ago by dsd

Xorg log from when this happens, many errors

comment:9 Changed 4 years ago by dsd

  • Action Needed changed from diagnose to package

Thanks. Your test of xf86-video-dove-0.3.6 confirms that it is not related to #12542.

This is due to a reordering of the source file list in Makefile.am (commit 7ec62e8d1) which caused the link order to change.

That should not make any difference, especially because I can't find any duplicate symbols in the objects where one might take precedence based on ordering, but this order makes a very clear difference between GNOME working and not. Probably indicates the presence of a deeper, difficult problem.

For now, go back to a known working link order. commit 4407aae

comment:10 Changed 4 years ago by dsd

  • Action Needed changed from package to add to build

Fixed in xorg-x11-drv-dove-0.3.8.xo4

Can someone test if this bug also exists on XO-1.75?

comment:11 Changed 4 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 13.2.0 build 5

comment:12 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

GNOME launches normally on 13.2.0 build 5, tested on XO-1.75 and XO-4.

Note: See TracTickets for help on using tickets.