Opened 4 years ago

Closed 4 years ago

#12681 closed defect (fixed)

cairo can't draw rectangle with transparency on xo-4 or xo-1.75

Reported by: godiard Owned by: dsd
Priority: normal Milestone: 13.2.0
Component: x window system Version: not specified
Keywords: Cc: sridhar, jvonau
Blocked By: Blocking:
Deployments affected: Australia Action Needed: add to build
Verified: no

Description

TestCase:

  • Start Paint.
  • Select the in the toolbar Shapes, the Rectangle tool.
  • Draw a few rectangles
  • In the colors palette, change the Opacity, to something different than 100%.
  • Try draw more rectangles.

Result:

  • No rectangle is drawn. All the other shapes works ok.

If test the same on xo-1 or xo-1.5, works, the problem is only with xo-1.75 and xo-4

Attached is a simpler testcase too, alpha.py: Should draw two rectangles and one circle.

Looks like some fast path is not working.

Attachments (1)

alpha.py (758 bytes) - added by godiard 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by godiard

comment:1 Changed 4 years ago by godiard

As a consequence of this bug, search in evince is not highlighted, only draw the border of the rectangle.

The code drawing the selection is libview/ev-view.c: line 4391

comment:2 Changed 4 years ago by dsd

  • Action Needed changed from diagnose to add to build

Thanks for the simple test case. Fixed in xf86-video-dove-0.3.10. We were incorrectly truncating repeat blits thinking that they were illegaly accessing out-of-bounds image data.

comment:3 Changed 4 years ago by godiard

Great!

comment:4 Changed 4 years ago by jvonau

  • Cc sridhar jvonau added
  • Deployments affected set to Australia

comment:5 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Tested 13.2.0 build 8 on XO-1.75 and XO-4, the alpha.py and Paint test cases work.

Note: See TracTickets for help on using tickets.