Ticket #12683 (closed defect: fixed)

Opened 16 months ago

Last modified 15 months ago

XO-1.75 speakers muted after headphone use

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 13.2.0
Component: kernel Version: not specified
Keywords: Cc:
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

In Nicaragua a large proportion of the XO-1.75s deployed in a city (running 12.1.0) are developing a condition where audio output through the speakers doesn't work (silence), but when headphones are connected, you do hear audio through the headphones.

I imagine the cause of this is to be playing sound through headphones while shutting down the laptop. At this point alsactl saves to disk the fact that the speakers are muted. This state will be restored on next boot, even if the headphones aren't connected.

The code in alc5631_spkr_mute() which deals with speaker mute/unmute based on headphone presence saves the speaker state before muting them when headphones are connected, and restores that state when the headphones are unplugged. That falls down in the face of alsactl save and restore logic.

Change History

Changed 16 months ago by dsd

  • next_action changed from never set to add to build

Fixed in arm-3.0-wip 501b555533763. Needs testing on XO-4.

Changed 16 months ago by dsd

XO-4 is not affected.

Changed 16 months ago by dsd

  • next_action changed from add to build to test in build

Test in 13.2.0 build 7.

Changed 15 months ago by Quozl

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

Tested, seems to be working fine.

  • fs-update 32007o2.zd, boot without headphones, start Speak, hear speakers,
  • plug in headphones, trigger Speak, hear headphones,
  • shutdown with power button double press, wait for power off,
  • remove headphone plug, boot, start Speak, hear speakers,
  • plug in headphones, trigger Speak, hear headphones,
  • shutdown with power button double press, wait for power off,
  • boot, start Speak, head headphones,
  • remove headphone plug, trigger Speak, hear speakers.
Note: See TracTickets for help on using tickets.