Opened 5 months ago

Closed 7 weeks ago

#12783 closed enhancement (fixed)

disable touchpad in e-book mode

Reported by: Quozl Owned by: Quozl
Priority: normal Milestone: 13.2.0-android
Component: android Version: Development build as of this date
Keywords: Cc: suyouxin
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Reproducer:

  • use the touchpad to make the mouse cursor visible,
  • rotate the upper half of the laptop 180 degrees and shut the lid; this is e-book mode,
  • observe the mouse cursor and button press events.

Observed behaviour:

  • cursor events continue,
  • mouse button press events may occur if the lid is pressed,
  • the application may received unintended input.

Desired behaviour:

  • touchpad is ignored.

OLPC OS for Sugar and Gnome ignores touchpad events in e-book mode.

Change History (1)

comment:1 Changed 7 weeks ago by Quozl

  • Action Needed changed from design to no action
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.