Opened 8 years ago

Closed 7 years ago

#1279 closed defect (duplicate)

Keyboard flat cable is too short, causing keyboard problems (missing sets of keys or the entire keyboard non-functional)

Reported by: jg Owned by: 90030501
Priority: high Milestone: BTest-3
Component: mechanical Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

The flat cable between the keyboard controller and the keyboard is too short. This can cause intermittent or complete loss of function of the keyboard.

At the expense of at least a half hour's labor to disassemble the keyboard and reassemble it, and possibly removing the screws holding the keyboard down so that it can be repositioned, it may be possible to recover functionality by reseating the cable in the zero insertion force connector (which is not entirely obvious how it works if you've never seen it.

This rework is painful enough, however, not to be for the fainthearted or fumble-fingered. It is the hardest part of the laptop to work on, short of resoldering components. Please contact us before attempting this in the field.

To be fixed in B3 by slightly lengthening the cable to allow more assembly tolerance.

Change History (3)

comment:1 Changed 8 years ago by garysu

  • Owner changed from wad to 90030501

comment:2 Changed 8 years ago by garysu

  • Component changed from hardware to mechanical

comment:3 Changed 7 years ago by wad

  • Milestone changed from BTest-4 to BTest-3
  • Resolution set to duplicate
  • Status changed from new to closed
  • Verified unset

Closed as a duplicate of #1427.

This should be fixed in B3 build.

Note: See TracTickets for help on using tickets.