Opened 10 years ago

Closed 10 years ago

Last modified 17 months ago

#1295 closed defect (fixed)

X is broken on 385 under qemu-ext3

Reported by: bemasc Owned by: J5
Priority: normal Milestone:
Component: distro Version:
Keywords: Cc: sj, J5
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Under Gentoo, running the default install of qemu-softmmu-0.8.2, I find that build 385-ext3 does not load X properly. X loads until it shows the "X" cursor on a black background, then falls back to the text-mode login prompt. The text-mode console works, and I was able to scp Xorg.0.log to a remote server.

Previous builds have run flawlessly.

Attachments (1)

Xorg.0.log (9.2 KB) - added by bemasc 10 years ago.
/var/Xorg.0.log from inside the emulator.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by bemasc

/var/Xorg.0.log from inside the emulator.

comment:1 Changed 10 years ago by cjb

Please also attach /home/olpc/.sugar/default/logs/shell.log, since it doesn't look like there's anything wrong with X here.

comment:2 Changed 10 years ago by bemasc

There is no .sugar/ directory inside /home/olpc.

Presumably it has not yet been created because sugar has not yet started.

comment:3 follow-ups: Changed 10 years ago by jg

  • Component changed from x window system to sugar
  • Milestone changed from Untriaged to BTest-3
  • Owner changed from jg to dcbw

You are going to have to do the heaving lifting on this one (unless it is easily reproducible on Fedora on Ubuntu), as we don't have gentoo laying around.

Marco, close this as won't fix if we can't reproduce it.

comment:4 in reply to: ↑ 3 Changed 10 years ago by rwh

I have the same behavior under qemu in Windows XP. Seems to be related to the fact that there is no free space in the image and directories like ~/.sugar can not be created (where is that message supposed to go; I only saw it after restarting X from the command line). After removing 8MB from the library it boots fine.

comment:5 follow-up: Changed 10 years ago by jg

  • Cc sj J5 added
  • Component changed from sugar to distro
  • Owner changed from dcbw to blizzard

Apparently, there amount of file system space allocated for the Qemu images is too small; if you delete (some of) the library content, you will have a working system.

This is getting fixed by moving the library out of the base system images.

comment:6 in reply to: ↑ 5 Changed 10 years ago by holtzman

I can confirm both the problem (X won't start due to insufficient free space) and the work-around (deleting some of the library. While removing the library from the base image will fix this, I would like to offer another thought -- since jffs2 is compressed, and ext3 is not, wouldn't it make sense to increase the size of the stock img filesystem?

comment:7 Changed 10 years ago by jg

No, the right solution is, since the library will need to be customized on a per country/region/school district/school basis to get the library out of the software distribution. This is planned for b3.

comment:8 in reply to: ↑ 3 Changed 10 years ago by roozbeh

  • Summary changed from X is broken on 385 under qemu to X is broken on 385 under qemu-ext3

Replying to jg:

(unless it is easily reproducible on Fedora on Ubuntu)

Easily reproducible here on FC6 with qemu-0.8.2-4.fc6.

comment:9 Changed 10 years ago by jg

  • Owner changed from blizzard to J5
  • Verified unset

J5, have we squeezed the size a bit so this has gone away?

In any case, at most this should be a release note; please add the release note about too much space to the software release notes and mark this wontfix, because when we've extracted SJ's monster, there will be plenty of space.

comment:10 Changed 10 years ago by J5

  • Resolution set to fixed
  • Status changed from new to closed

newer builds do not add the Library

comment:11 Changed 17 months ago by Quozl

  • Milestone BTest-4 deleted

Milestone BTest-4 deleted

Note: See TracTickets for help on using tickets.