Opened 8 years ago

Closed 7 years ago

#1730 closed defect (fixed)

After suspend/resume, camera shows strange colormap

Reported by: cjb Owned by: jfuhrer
Priority: high Milestone: Trial-2
Component: distro Version:
Keywords: power Cc: jg, olpc-dev@…, corbet
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

After suspend/resume on my B3, the camera activity shows a strange colormap. When I quit the camera activity and restart it, the colors are back to normal. If I suspend/resume again, they go strange once more.

Photo attached. The red object is a (very bright white) light.

Attachments (1)

xv.activity.tar.gz (49.2 KB) - added by erikb 8 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by cjb

Too large to attach, so it's here:

http://dev.laptop.org/~cjb/camera.jpg

Note from the images at the bottom of the screen that the effect doesn't show up in screenshots, even while it's doing so in the Xv main image.

comment:2 Changed 8 years ago by jg

  • Keywords power added

comment:3 Changed 8 years ago by kimquirk

  • Milestone changed from Trial-2 to BTest-4

Would like to fix this on the B4 boards.

comment:4 Changed 8 years ago by kimquirk

Would like to fix this on the B4 boards.

comment:5 Changed 8 years ago by jg

  • Milestone changed from BTest-4 to Trial-2

comment:6 Changed 8 years ago by erikb

  • Cc olpc-dev@… added

uploaded a simple app which just displays video to help with debugging

comment:7 Changed 8 years ago by erikb

not sure why, but you have to launch the attached activity from the console

sugar-activity xv

Changed 8 years ago by erikb

comment:8 Changed 8 years ago by cjb

I get a black screen and no camera LED comes on, no matter how I launch the (latest) xv.activity. The stock camera.activity works.

comment:9 Changed 8 years ago by cjb

Ah, I get a traceback about ActivityToolbox not existing. I bet 406.15 is too old, then.

comment:10 Changed 8 years ago by erikb

  • Cc JordanCrouse removed
  • Owner changed from corbet to JordanCrouse

It seems that this bug is downstream of v4l2. Explanation: pictures taken by the camera activity after suspend have the correct colors... and those pictures are made by grabbing buffers from the same pipeline to the xv sink (where they are displayed in technicolor).

comment:11 Changed 8 years ago by cjb

  • Cc corbet added

Reproduced with pure xvtest, which also gets corrupted on resume. Over to Jordan, corbet is off the hook. :)

comment:12 Changed 7 years ago by JordanCrouse

  • Owner changed from JordanCrouse to kimquirk

Fixed twice... :) Basically, we were only restoring 255 of the LUT table entries - totally missing the last one, which was resulting in the pretty colors. This was fixed by adjusting the offsets in the lxfb driver. However - we should have also been setting up the video palette when we started up video; had we been doing that, we wouldn't have seen this problem. So, both the x driver and the kernel driver were fixed, and we're happy.

Reassigning to kim to verify.

comment:13 Changed 7 years ago by kimquirk

  • Owner changed from kimquirk to jfuhrer
  • Priority changed from blocker to high

Since it is believed to be fixed, I am lowering the priority.
John - can you try to retest this?

comment:14 Changed 7 years ago by cjb

  • Resolution set to fixed
  • Status changed from new to closed

Tested fixed, closed.

Note: See TracTickets for help on using tickets.