Opened 7 years ago

Closed 7 years ago

#1916 closed defect (fixed)

"Copy to clipboard" option in Journal does nothing

Reported by: jfuhrer Owned by: tomeu
Priority: normal Milestone: Trial-2
Component: journal-activity Version:
Keywords: Cc: eben
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

OFW: Q2C18
Build: 485

Somewhat related to #1888, but to the best of my knowledge that's a separate problem.

The "Copy to clipboard" functionality in Journal was added recently. According to the HIG, any object stored in the journal should be able to be copied to the clipboard and stored there. It seems as though this is halfway-implemented. Right now, one can select a journal entry and press the "copy to clipboard" key, and a blank icon is added to the left side of the frame (the clipboard section). Selecting this icon is supposed to determine what will be pasted if the paste function is used, but it does not. Pasting with this selection does nothing.

Change History (7)

comment:1 Changed 7 years ago by tomeu

If you can paste or drop an object depends on the type of data it is and the data types that can accept the place where you paste or drop. As an example, you can drop images and text in Write but not sounds.

Can you add details of which kinds of journal entries fail, and where you were trying to drop or paste?

comment:2 follow-up: Changed 7 years ago by jfuhrer

Sure, though I'm not quite sure of what exactly copying an entire journal entry to the clipboard should be doing. The HIG isn't quite clear on it - I'm assuming that it just attempts to copy the entire contents of the activity you were working in - copy all text if you were working in Write, the whole image if you were working in Paint, etc. Either way, though, the creation of a blank icon with no indicator of the type seems problematic.

When I found the problem I simply typed "Test" into Write, closed the activity, looked at the Journal entry for my Write, did "Copy to clipboard," and then tried to paste the selection back into Write. So, unless copying a journal entry to clipboard doesn't do what I think it does, it should have no problem pasting text into Write. If copying a Journal entry does something more complex, then, well...it needs an icon of its own at the very least.

comment:3 follow-up: Changed 7 years ago by jfuhrer

For the record, the Copy to clipboard option works fine if the journal entry is already a clipboard selection. If that's all the feature was intended for, then the user should probably not be allowed to copy non-clipboard journal entries.

comment:4 in reply to: ↑ 2 ; follow-up: Changed 7 years ago by tomeu

Replying to jfuhrer:

Sure, though I'm not quite sure of what exactly copying an entire journal entry to the clipboard should be doing. The HIG isn't quite clear on it - I'm assuming that it just attempts to copy the entire contents of the activity you were working in - copy all text if you were working in Write, the whole image if you were working in Paint, etc.

Yeah, this is my understanding and also what I implemented.

Either way, though, the creation of a blank icon with no indicator of the type seems problematic.

Yup, this is a bug in sugar's clipboard.

When I found the problem I simply typed "Test" into Write, closed the activity, looked at the Journal entry for my Write, did "Copy to clipboard," and then tried to paste the selection back into Write. So, unless copying a journal entry to clipboard doesn't do what I think it does, it should have no problem pasting text into Write. If copying a Journal entry does something more complex, then, well...it needs an icon of its own at the very least.

And not pasting the text is another bug, but what I meant is that we're going to have lots of bugs related to things not pasting where it is expected. We need to enter a separate ticket for every combination of data type and activity.

comment:5 in reply to: ↑ 3 Changed 7 years ago by tomeu

  • Cc eben added

Replying to jfuhrer:

For the record, the Copy to clipboard option works fine if the journal entry is already a clipboard selection. If that's all the feature was intended for, then the user should probably not be allowed to copy non-clipboard journal entries.

No, all entries can be copied to the clipboard. If you can paste in an activity or not depends on the data types this activity can accept.

CC'ing Eben as perhaps he wants to correct me.

comment:6 in reply to: ↑ 4 Changed 7 years ago by jfuhrer

Replying to tomeu:

And not pasting the text is another bug, but what I meant is that we're going to have lots of bugs related to things not pasting where it is expected. We need to enter a separate ticket for every combination of data type and activity.

Just to be completely clear, as I don't really understand this at the programming level - it seems as though the problem occurs right at the point where you try to copy a non-clipboard journal entry to the clipboard, and that copy selection can't be pasted into ANY program. Creating one ticket for a Paint journal entry being unable to be pasted into Paint, and another for its being unable to be pasted into Write, seems redundant since it looks like the selection is just messed up right at the point where it tried to copy it.

I can get on this if you want, I just want to make sure I'm not misunderstanding and needlessly flooding trac with redundant tickets.

comment:7 Changed 7 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

The concrete problem here is that Write is not accepting drops of its own files, and also the same happens with Paint. But these are issues that need to be solved by each activity's authors. This is not an issue neither with Sugar nor with the Journal.

Note: See TracTickets for help on using tickets.