Opened 7 years ago

Closed 7 years ago

#1918 closed enhancement (duplicate)

Notification system for downloads

Reported by: jfuhrer Owned by: tomeu
Priority: normal Milestone: Not Triaged
Component: sugar Version:
Keywords: read Cc: tomeu, marco, Eben
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

OFW: Q2C18
Build: 485

When a pdf file is downloaded, Read is supposed to auto-launch and open the file. However, when I download a pdf, it is added to the clipboard on the left side of the Frame instead. The file can be opened from the Journal as was intended, but the Read activity does not open automatically (as I understand it is supposed to).

Steps taken:

  1. Open Browse. Google for pdf.
  2. Download the W-4 form, the third hit.
  3. fw4.pdf should appear in your clipboard. (The open option does nothing.)
  4. There will be an entry in the journal for "File fw4.pdf downloaded from http://www.irs.gov/pub/irs-pdf/fw4.pdf"
  5. Clicking this entry and clicking Resume can open the file normally.

Attachments (1)

PIC00250.JPG (178.1 KB) - added by chiaying.lin 7 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 7 years ago by marco

  • Component changed from sugar to interface-design
  • Owner changed from dcbw to Eben

I think this is actually the wanted behavior... (not auto-opening). Reassigning to Eben to make sure.

comment:2 Changed 7 years ago by chiaying.lin

BIOS: Q2C18 Image: 494
After download a pdf file from web site.
It is added to the clipboard on the left side of the Frame instead.
Click the open option(PIC00250.JPG), but Read not open.-->problem
Open Read manually and click open option(PIC00250), Read didn't open the pdf file.-->problem

Changed 7 years ago by chiaying.lin

comment:3 Changed 7 years ago by Eben

  • Milestone changed from Trial-2 to CTest

We need to push off on this until we actually build a notification system. Downloads should not wind up on the clipboard at all, since it makes the paste action slightly non-deterministic, breaking the chain of those items explicitly added. I don't think we'll support auto-launch by default, but we will have a notification which informs the user when the download is complete, and which has several available actions including the option to open the downloaded file.

comment:4 Changed 7 years ago by jg

  • Milestone changed from CTest to Trial-3

comment:5 Changed 7 years ago by Eben

Once ticket #2555 is taken care of, the download will actually appear as an in-progress Journal entry. This eliminates the need to place it on the clipboard. Of course, it doesn't solve the problem of what happens when the download completes.

We could have Browse fire off an alert, indicating the download is complete. We could also have the Journal provide the alert. I don't think that it's a good idea to automatically launch a new activity instance, but I would like to offer the option to open it once it finishes. We need to do a little more work on the design for notifications, still.

comment:6 Changed 7 years ago by Eben

  • Cc tomeu marco added
  • Component changed from interface-design to sugar
  • Milestone changed from Trial-3 to FRS
  • Owner changed from Eben to dcbw

It's safe to say that we won't have a notification system in place by trial 3, so, I'm pushing this to FRS. In the meantime, I think that we should handle downloads via "in-progress" journal entries (#2555). They will thus be accessible as the most recent entry in the Journal for easy launching. We won't auto-launch them for trial 3.

comment:7 Changed 7 years ago by Eben

  • Owner changed from dcbw to tomeu

comment:8 Changed 7 years ago by tomeu

  • Cc Eben added

Downloads already appear as in progress entries in the journal.

After removing downloads from the clipboard this will be closed.

Eben, Marco, do you agree?

comment:9 Changed 7 years ago by Eben

I think we'll likely still want to add completed downloads to some form of notification system, but until then, yes, I think that this will be sufficiently resolved.

comment:10 Changed 7 years ago by marco

  • Milestone changed from First Deployment, V1.0 to Untriaged
  • Type changed from defect to enhancement

Do we want to add the notification system for FRS?

comment:11 Changed 7 years ago by marco

  • Summary changed from Read does not auto-launch when a pdf is downloaded to Notification system for downloads

comment:12 Changed 7 years ago by Eben

I really think we need at least a basic notification system by FRS. It really solves a lot of problems, and will provide much better feedback across the board. At this stage, I think we'll use the activity-based non-modal notification dialogs (you'll have to be in Browse to get the notification). System level notifications are separate.

comment:13 Changed 7 years ago by tomeu

System level notifications are in the roadmap for FRS. Perhaps we should go for non-modal alerts instead.

Seems to me that non-modal alerts would be lower risk and would provide a more needed functionality.

comment:14 Changed 7 years ago by marco

I agree with Tomeu here.

comment:15 Changed 7 years ago by tomeu

  • Resolution set to duplicate
  • Status changed from new to closed

Simon is implementing this as part of #3797.

Note: See TracTickets for help on using tickets.