Ticket #1924 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Selecting text in Abiword automatically switches to Text tab

Reported by: jfuhrer Owned by: uwog
Priority: normal Milestone: Update.1
Component: write-activity (abiword) Version:
Keywords: Cc: eben
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

OFW: Q2C18 Build: 485

I'm not sure if this is intended functionality, but it may need to be rethought if it is. Selecting text in Abiword automatically switches to the Text tab (where you change bold/italics/fontsize/etc.). This can be very annoying if you want to be copying/pasting text instead and it keeps switching on you.

Attachments

Write.log (0.8 kB) - added by jfuhrer 7 years ago.
shell.log (1.5 kB) - added by jfuhrer 7 years ago.

Change History

Changed 7 years ago by jfuhrer

Changed 7 years ago by jfuhrer

Changed 7 years ago by uwog

  • cc eben added

This is intended behavior; same when you select an image: the image tab will be selected. Same for tables.

Eben could shed some light on this functionality.

Changed 7 years ago by HoboPrimate

Has there been any thought to the problem of copying and pasting stuff using the the Edit toolbar icons (very tyring)? Perhaps in a future release, undo/redo and copy/paste should be on the Frame, since they will be needed for almost all activities.

Eduardo

Changed 7 years ago by HoboPrimate

This problem also will apply to other activities, especially those which are more advanced: When a object within this activity can be manipulated by various tools situated in different toolbars, having the active toolbox be switched when that object is selected, will get in the way rather than help the user work-flow. In fact, this already happens in Write, with the Format toolbox. The user might be use Style on his text, and after selecting some piece of text, have the toolbox be switched to "Text".

Eben, have you planned a future way to show more than one toolbox at the same time ? This would, at a pain of decreasing real space, ease the problem, while keeping the goodness of contextual tool switching/showing.

Changed 7 years ago by HoboPrimate

Please disregard the bad quality and errors, but is this doable or wanted? http://wiki.laptop.org/go/Image:Activity-bad-mockup.png

I'll shut up now, there is probably more important stuff for 1.0 and even 1.1 version of Sugar.

Changed 7 years ago by uwog

  • milestone changed from Trial-3 to First Deployment, V1.0

Changed 7 years ago by uwog

  • status changed from new to closed
  • resolution set to duplicate

Marking this a dupe of 1924 (i know the latter one is newer, but it has a good suggestion on the fix).

Note: See TracTickets for help on using tickets.