Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1927 closed defect (fixed)

Avahi causing sugar-presence-service to peg CPU and fill disk?

Reported by: Zack Owned by: smcv
Priority: blocker Milestone: Trial-2
Component: presence-service Version:
Keywords: Cc: Zack, smcv
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: yes

Description

When there's no Internet connection, Avahi seems to be bouncing around. The result of this is that sugar-presence-service takes so much CPU time that the UI becomes unresponsive.

With an uptime of 35 minutes on a freshly installed build 486, sugar-presence-service.log is 1.5MiB and growing.

Filing this on NM because Avahi has no component.

INFO - s-p-s.linklocal_plugin: Avahi disappeared from the system bus - stopping...
INFO - s-p-s.linklocal_plugin: Avahi appeared on the system bus (:1.13) - starting...
DEBUG - s-p-s.telepathy_plugin: <LinkLocalPlugin object (telepathy_plugin+TelepathyPlugin) at 0x82a67ac>: Starting up...
INFO - s-p-s.linklocal_plugin: Avahi disappeared from the system bus - stopping...
DEBUG - s-p-s.buddy: Failed to preload buddy properties, will try again after Connect(): org.freedesktop.DBus.Error.UnknownMethod: Method "SetProperties" with signature "a{sv}" on interface "org.laptop.Telepathy.BuddyInfo" doesn't exist
INFO - s-p-s.linklocal_plugin: Avahi appeared on the system bus (:1.14) - starting...
DEBUG - s-p-s.telepathy_plugin: <LinkLocalPlugin object (telepathy_plugin+TelepathyPlugin) at 0x82a67ac>: Starting up...
DEBUG - s-p-s.telepathy_plugin: <LinkLocalPlugin object (telepathy_plugin+TelepathyPlugin) at 0x82a67ac>: connecting...
INFO - s-p-s.linklocal_plugin: Avahi disappeared from the system bus - stopping...
DEBUG - s-p-s.telepathy_plugin: <LinkLocalPlugin object (telepathy_plugin+TelepathyPlugin) at 0x82a67ac>: Connect() succeeded
INFO - s-p-s.linklocal_plugin: Avahi appeared on the system bus (:1.15) - starting...
[...]
INFO - s-p-s.linklocal_plugin: Avahi appeared on the system bus (:1.2725) - starting...

And this is still counting. Sometimes the messages come in a different order; there's no exact sequence that they follow, it seems.

Change History (10)

comment:1 Changed 7 years ago by smcv

  • Cc smcv added

I think this is a duplicate of #1854. Is/was your version of dbus-python less than 0.82.0?

comment:2 Changed 7 years ago by cjb

This was done with the latest build, which uses:

---> Package dbus-python.i386 0:0.82.0-2.fc7 set to be updated

comment:3 Changed 7 years ago by smcv

  • Component changed from network manager to presence-service
  • Owner changed from dcbw to smcv

It's possible that this is related to, or the same as, #1874. I'll investigate as soon as I can get a working jhbuild.

comment:4 Changed 7 years ago by cjb

Verified still present in 499. Happens every time..

comment:5 Changed 7 years ago by smcv

I can't reproduce this in 499 on a B3. Could someone who *can* reproduce this please provide me with their ~/.sugar/default/logs/* and /var/log/messages?

comment:6 Changed 7 years ago by marco

I'm not seeing this with 499 updated. It might be easily confused with #1874 so once that's fixed it make sense to test again.

comment:7 Changed 7 years ago by marco

  • Resolution set to fixed
  • Status changed from new to closed

I think this is fixed in 505. Please open a new ticket if you see something similar again. There was several issues with similar symptoms which I believe are fixed now.

comment:8 Changed 7 years ago by coderanger

Adding reporter to CC list

comment:9 Changed 7 years ago by coderanger

  • Cc Zack added

Adding reporter to CC list

comment:10 Changed 7 years ago by Zack

  • Verified set
Note: See TracTickets for help on using tickets.