Ticket #1935 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Shared activities stay in the mesh view when no one is using them

Reported by: jfuhrer Owned by: morgs
Priority: high Milestone: Trial-3
Component: presence-service Version:
Keywords: Cc: gdesmott
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

OFW: Q2C18 Build: 485

Is this the intended behavior? If I share an activity, it appears in the Neighborhood view, but it will remain in the Neighborhood view even after I quit out of the activity. Should activity icons for shared activities be persisting in the view even after they're empty?

Attachments

presenceservice.log (115.4 kB) - added by jfuhrer 7 years ago.
Record.log (19.9 kB) - added by jfuhrer 7 years ago.
presenceservice.2.log (74.7 kB) - added by jfuhrer 7 years ago.
Write.log (3.7 kB) - added by jfuhrer 7 years ago.

Change History

  Changed 7 years ago by marco

  • priority changed from normal to high

Nope, not intended. Not sure if sugar or ps bug.

  Changed 7 years ago by morgs

  • owner changed from dcbw to morgs
  • status changed from new to assigned
  • component changed from sugar to presence-service

  Changed 7 years ago by marco

morgs, what's the status here? You said you partially fixed this at some point... What is left?

follow-ups: ↓ 5 ↓ 8   Changed 7 years ago by jfuhrer

As of 514 the icon will drop off in everyone's mesh view EXCEPT the XO that created and shared the activity...maybe that's what he was referring to?

in reply to: ↑ 4   Changed 7 years ago by morgs

Replying to jfuhrer:

As of 514 the icon will drop off in everyone's mesh view EXCEPT the XO that created and shared the activity...maybe that's what he was referring to?

That is the current status. I'll try debug it with the other Collaborans at Guadec.

  Changed 7 years ago by jg

Not clear to me that this isn't pretty serious, when taken to scale in schools.

We have trials of several hundred laptops underway.

If you have time investigate to see if there is a simple fix.

I'm not going to push this one out to trial-3 yet.

  Changed 7 years ago by gdesmott

  • cc gdesmott added

Morgs: Any news about this bug? Does it occur when using Gabble, Salut, both?

in reply to: ↑ 4   Changed 7 years ago by morgs

Replying to jfuhrer:

As of 514 the icon will drop off in everyone's mesh view EXCEPT the XO that created and shared the activity...maybe that's what he was referring to?

This should be fixed as of build 515. I'm not aware of specifics of this still happening. If so, please indicate which build, whether gabble or salut, and include activity log and presenceservice.log.

  Changed 7 years ago by jfuhrer

Actually, as of 532 the problem seems to still occur occasionally, with activity icons getting stuck on OTHER XO's screens rather than the XO that created them. Here are the logs from a B3 that had a Record activity he participated in (which was started by a B4) get stuck in his Neighborhood view. I'm using Salut.

Changed 7 years ago by jfuhrer

Changed 7 years ago by jfuhrer

  Changed 7 years ago by jfuhrer

Here's one in 535 with the activity icon getting stuck on the screen of the XO that created it.

Changed 7 years ago by jfuhrer

Changed 7 years ago by jfuhrer

  Changed 7 years ago by morgs

The problem in 535 was due to D-Bus timeouts which cause unpredictable behaviour.

I'll continue checking salut.

  Changed 7 years ago by jg

  • milestone changed from Trial-2 to Trial-3

  Changed 7 years ago by marco

  • status changed from assigned to closed
  • resolution set to fixed

morgs: marcopg: 1935 is mostly remedied, but multiple things exist which can cause this behaviour - like someone powering off without stopping a shared activity, or suspending even

Please open separate tickets if you find cases where this still happen.

Note: See TracTickets for help on using tickets.