Opened 7 years ago

Closed 7 years ago

#1960 closed defect (fixed)

Connect's activity buttons don't always display properly

Reported by: jfuhrer Owned by: morgs
Priority: normal Milestone: Trial-2
Component: connect-activity Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

OFW: Q2C18
Build: 488

When opening Connect, the side panel and the activity buttons (close, open, share) sometimes don't display. You just get the game board. I'm not sure what the steps are to reproduce this bug.

Attachments (1)

Connect.log (1013 bytes) - added by morgs 7 years ago.
Connect log showing traceback when PS is not connected

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by morgs

  • Status changed from new to assigned

This happens when the PresenceService fails to connect to either connection manager - telepathy-gabble (XMPP server) or telepathy-salut (XMPP Link Local). I'll look into a way to make them appear, along with some sort of indication that sharing is not possible (which means that the activity can't be used at all...)

It can be reproduced in jhbuild by running:
$ PRESENCE_SERVICE_DEBUG=disable-salut,disable-gabble ./sugar-jhbuild run

Changed 7 years ago by morgs

Connect log showing traceback when PS is not connected

comment:2 Changed 7 years ago by morgs

Same as #1624

comment:3 Changed 7 years ago by morgs

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by making those UI elements display even when the PS doesn't connect.

Fix should go into build 501.

comment:4 Changed 2 years ago by Micah

  • Blocked By 12152 added

comment:5 Changed 2 years ago by Micah

  • Blocked By 12152 removed
Note: See TracTickets for help on using tickets.