Opened 8 years ago

Closed 8 years ago

#1967 closed defect (fixed)

XO user names sometimes don't display correctly in mesh view

Reported by: jfuhrer Owned by: smcv
Priority: normal Milestone: Trial-3
Component: telepathy-gabble Version:
Keywords: Cc: gdesmott, morgs
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

OFW: Q2C18
Build: 488

XO user names sometimes come up as a long string of gibberish. The username "Kim-B2" came up as "d45aa41633a9531f3b04a194ad6877472f5d2fb" for me (though it had previously displayed the same name correctly.) It's always other XO names, though - the user's own name always displays just fine.

Attachments (1)

presenceservice.log (30.8 KB) - added by jfuhrer 8 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by marco

  • Component changed from network manager to presence-service
  • Owner changed from dcbw to morgan

Sounds like presence-service, or possibly sugar.

comment:2 Changed 8 years ago by smcv

  • Owner changed from morgan to morgs

comment:3 Changed 8 years ago by smcv

telepathy-gabble uses the username part of the JID as a fallback if a more sensible name can't be found. This is usually a good move, but in the case of the OLPC, the JID is indeed a long string of gibberish.

If you can provide telepathy-gabble.log and presence-service.log when this issue appears, that would be very helpful. Ideally, run Gabble with GABBLE_DEBUG=all LM_DEBUG=net in its environment, although I realise this can be difficult on an XO.

"killall telepathy-gabble ; GABBLE_DEBUG=all LM_DEBUG=net telepathy-gabble" should do the trick.

comment:4 Changed 8 years ago by smcv

  • Owner changed from morgs to smcv

I think this is due to a race condition in telepathy-gabble: the vCard updating race <https://bugs.freedesktop.org/show_bug.cgi?id=11201> might be causing us to save the avatar or the alias but not both.

I'll leave this as a PS bug, but I think it's really Gabble's fault.

comment:5 Changed 8 years ago by jfuhrer

Here's the presence service log...there was no telepathy-gabble.log or telepathygabble.log.

Changed 8 years ago by jfuhrer

comment:6 Changed 8 years ago by morgs

comment:7 in reply to: ↑ description Changed 8 years ago by smcv

I'm working on a fix for the Gabble bug linked above, which I think will fix this.

comment:8 Changed 8 years ago by gdesmott

  • Cc gdesmott added

comment:9 Changed 8 years ago by smcv

fd.o #11201, which I believe is the underlying bug that causes this, has been fixed upstream; the fix and regression test will be in Gabble 0.5.13.

I've said this before on IRC and possibly in e-mail, but just to make sure it's documented here: this bug shouldn't affect us at the moment, because avatars are involved in the race condition, and we disabled those for Trial2 for performance reasons. We should make sure avatars aren't re-enabled until Gabble 0.5.13, or a backport of my fix, is in OLPC builds.

comment:10 Changed 8 years ago by morgs

  • Cc morgs added

comment:12 in reply to: ↑ description Changed 8 years ago by smcv

  • Component changed from presence-service to telepathy-gabble

The current Gabble version actually makes this worse, due to a bug in upstream version 0.5.13 (setting the vCard fails completely). I'll have a build ready tomorrow which I believe should fix it in all cases (hopefully synchronizing with upstream version 0.5.14, which will be a bugfix-only release).

comment:13 Changed 8 years ago by smcv

I've put an updated Gabble which should fix this in #3142. It identifies itself as 0.5.14.1 in logs (we made a bugfix-only upstream release 0.5.14 today, although the announcement mail hasn't gone out because freedesktop.org is broken).

comment:14 Changed 8 years ago by smcv

  • Resolution set to fixed
  • Status changed from new to closed

0.5.14.1 landed in build 570.

Note: See TracTickets for help on using tickets.