Opened 7 years ago

Closed 7 years ago

#2059 closed defect (worksforme)

iwconfig, iwlist hang indefinitely

Reported by: Zack Owned by: marcelo
Priority: blocker Milestone: Trial-2
Component: wireless Version:
Keywords: Cc: , Zack
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

About 15 minutes after I booted an XO onto a freshly-installed build 496, I tried executing 'iwconfig' and 'iwlist scan'. These simply hung after outputting lo, never getting to msh0 or eth0.

Change History (7)

comment:1 Changed 7 years ago by kimquirk

  • Milestone changed from Untriaged to Trial-2

comment:2 Changed 7 years ago by jg

Marcelo, what's the current state?

comment:3 Changed 7 years ago by marcelo

Zack,

We have seen such problems in early testing but not recently.

Can you please edit /etc/modprobe.d/olpc.conf.dist and add the following line:

options libertas libertas_debug=0xffffffff

Then reboot the machine, reproduce the problem, and save the output of dmesg:

# dmesg > dmesg.out

Then attach dmesg.out to this bug entry?

Thanks

comment:4 Changed 7 years ago by coderanger

Adding reporter to CC list

comment:5 Changed 7 years ago by coderanger

  • Cc Zack added

Adding reporter to CC list

comment:6 Changed 7 years ago by Zack

I haven't seen this happen since reporting it.

comment:7 Changed 7 years ago by jg

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.