Opened 7 years ago

Closed 7 years ago

#2182 closed defect (fixed)

Plugging in an XO with a low battery causes immediate poweroff and EC lockup

Reported by: cscott Owned by: gary
Priority: blocker Milestone: Trial-3
Component: hardware Version:
Keywords: Cc: wad, smithbone
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Running build 492. I returned to my XO to find it with very low battery (red battery light illuminated). It was still powered up. I brought it over to its charger, and it immediately shut off (no linux shutdown process) when I plugged it in. Not only did it power off, the battery light turned off as well. The machine wouldn't turn on, and plugging and unplugging the adaptor did not cause the battery light to reilluminate. With the power cord out, I took out the battery and replaced it. I then plugged the XO back in, and the expected amber battery light went on. I pressed the power button, and it turned on and booted.

Change History (10)

comment:1 Changed 7 years ago by jg

  • Cc wad added
  • Component changed from distro to embedded controller
  • Milestone changed from Untriaged to Trial-2
  • Owner changed from jg to David.Lin
  • Priority changed from normal to blocker

comment:2 Changed 7 years ago by jg

  • Cc smithbone added

comment:3 Changed 7 years ago by cscott

I suspect that, with low battery voltage, plugging in the power adaptor causes enough momentary current draw (due to a suddenly imposed uncharged capacitance?) to glitch the supply rails and lock up the EC. I haven't looked at the schematic, so I don't know if this wild guess is at all possible or plausible.

comment:4 Changed 7 years ago by David.Lin

Can you tell me machine type and OpenFirmware version?

comment:5 Changed 7 years ago by David.Lin

  • Component changed from embedded controller to hardware
  • Owner changed from David.Lin to gary

comment:6 Changed 7 years ago by jg

battery charger IC problem, according to Quanta.

comment:7 Changed 7 years ago by wad

Has this problem been seen on B3 machines, or just on B4s ?

comment:8 Changed 7 years ago by Terry Su

Kenl,

So we final solution for fix ticket #2182

  1. R269 wire to VA2.
  1. Reserve a capacitor in parallel with R270. à Populate or Depopulate in C stage?
  1. Remove D1.
  1. Change R269 and R270 value to 1M and 158K.

John,

Above is our conclusion for ticket # 2182, would you have else concern ?

Best Regards,

Terry Su

Quanta Computer Inc.

EPBU R&D H/W

TEL: +886-3-3272345 ext. 15280

FAX:+886-3-328-5048


From: kenl Lin (林世堅)
Sent: Friday, July 20, 2007 2:58 PM
To: Terry Su (蘇泰利)
Cc: 'richard@…'; Arnold Kao (高顯宗); 'John Watlington'
Subject: RE: Low Battery

Hi Terry,

If change the net of R269 from VA1 to VA2 can solve system shutdown issue.
But the resistor value of R269 and R270 need to change to 1M-ohm and 158K-ohm to avoid leakage current and D1 also can remove it.

Best Regards !

Ken Lin

Quanta Computer Inc.

NB5 Research & Development System & Electronics

Tel: (03)3272345 # 11549

Address: 211, Wen Hwa 2nd Rd,Kuei Shan Hsiang,Tao Yuan 33377, Taiwan, ROC.


From: Terry Su (蘇泰利)
Sent: Friday, July 20, 2007 12:50 PM
To: kenl Lin (林世堅)
Cc: richard@…; Arnold Kao (高顯宗); John Watlington
Subject: RE: Low Battery

Kenl,

Could you reply John mail about power circuit change ?

moving the top of R269 to VA2 instead of VA1 ?

or adding a capacitor in parallel with R270 ?

Best Regards,
Terry Su

Quanta Computer Inc.
EPBU R&D H/W
TEL: +886-3-3272345 ext. 15280
FAX:+886-3-328-5048


From: John Watlington wad@…
Sent: Friday, July 20, 2007 12:37 PM
To: Terry Su (蘇泰利)
Cc: John Watlington; richard@…; Arnold Kao (高顯宗)
Subject: Re: Low Battery

How about moving the top of R269 to VA2 instead of VA1 ?
or adding a capacitor in parallel with R270 ?

John

On Jul 20, 2007, at 12:01 AM, <Terry.Su@…> wrote:

John,

We can replicate it and our power team feedback the cause from Q34
soft start circuit cause AC/DC switch VIN have drop to under 5V.
The U65 LDO detect VIN fail then assert OVR to EC reset, so system
shutdown.They tried remove C324 this symptom was disappear, but we still
check this solution have another side effect.

Best Regards,
Terry Su
Quanta Computer Inc.
EPBU R&D H/W
TEL: +886-3-3272345 ext. 15280
FAX:+886-3-328-5048


From: John Watlington wad@…
Sent: Friday, July 20, 2007 11:51 AM
To: Terry Su (蘇泰利)
Cc: John Watlington; Richard Smith; Arnold Kao (高顯宗)
Subject: Low Battery

Any progress on the low battery ? http://dev.laptop.org/ticket/2182
Have you been able to replicate it ? I haven't, although I see the
same effect you do when trying. ACOK# has a very strange behavior. I didn't
have time to take a look at the input, but I wonder if this has to do with
particular power adapters not reacting well to the sudden change in current when
they are plugged in.More bulk capacitance needed on the input ?

John

comment:9 follow-up: Changed 7 years ago by jg

  • Milestone changed from Trial-2 to CTest

Supposed to be fixed in CTest.

comment:10 in reply to: ↑ 9 Changed 7 years ago by rsmith

  • Resolution set to fixed
  • Status changed from new to closed

Replying to jg:

Supposed to be fixed in CTest.

Fixed in ctest

Note: See TracTickets for help on using tickets.