Opened 8 years ago

Closed 8 years ago

Last modified 5 weeks ago

#2402 closed defect (fixed)

Key wakeup is less reliable than power button wakeup

Reported by: cjb Owned by: dilinger
Priority: blocker Milestone:
Component: kernel Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

B4, latest everything.

Pressing the power button while in suspend gets the display back immediately. Pressing a keyboard/game key sometimes gets us a hang with a black (as distinct from "off") screen. Serial should help work out what's happening.

Change History (5)

comment:1 Changed 8 years ago by cjb

Tried both Q2C18 and Q2CD7F, same result.

comment:2 Changed 8 years ago by cjb

John Gilmore pointed out that the EC has a line to the DCON to wake it immediately on keypress. That could be what's happening with the black screen.

comment:3 Changed 8 years ago by dilinger

Ok, the black screen is from DCON being in sleep mode, I believe. I have been unable to reproduce this on my B3, but I suspect what you saw was the DCON source switch/unfreeze failing..

comment:4 Changed 8 years ago by jg

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 5 weeks ago by Quozl

  • Milestone Trial-2 deleted

Milestone Trial-2 deleted

Note: See TracTickets for help on using tickets.