Opened 7 years ago

Closed 7 years ago

#2481 closed defect (fixed)

Files appear in journal when copied to USB stick, but can't be opened

Reported by: jfuhrer Owned by: tomeu
Priority: blocker Milestone: Trial-2
Component: sugar-datastore Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

OFW: Q2C18
Build: 536

Downloaded the file "fw4.pdf" to the clipboard. Inserted the USB stick and had the icon appear in the Journal. Selected "add to journal" on the clipboard entry's context menu. Then, I went to the journal and tried dragging both the entry "Clipboard object; fw4.pdf" and "File fw4.pdf downloaded from http://www.irs.gov/pub/irs-pdf/fw4.pdf" (in the Journal entry list, resuming either of these will open the file). Entries for both of these appeared in the USB stick's entry list. However, I was unable to properly resume these entries, both when I tried to resume them from the USB stick, and when I copied them to the clipboard and then tried to resume them. When I opened them directly from the Journal, the Read activity started, but didn't load anything. When I copied them to the clipboard, they lost their name and icon, and could not be opened. #2475 explains the latter, but even in that case the files could at least be opened directly from the USB stick. It seems as though something's being lost when the files are copied to the USB stick.

Attachments (2)

datastore.log (5.2 KB) - added by jfuhrer 7 years ago.
Journal.log (78.8 KB) - added by jfuhrer 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by jfuhrer

Changed 7 years ago by jfuhrer

comment:1 Changed 7 years ago by jg

  • Milestone changed from Untriaged to Trial-2

comment:2 Changed 7 years ago by tomeu

Fixed in 539.

comment:3 Changed 7 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.