Ticket #2508 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

Holding power button is restarting instead of shutting off

Reported by: jfuhrer Owned by: wad
Priority: blocker Milestone: CTest
Component: hardware Version:
Keywords: Cc: mlj, wad, rsmith
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

OFW: Q2C18 Build: 536

This doesn't happen all the time, but I've noticed many times that when I hold the power button to shut off the XO, the screen sometimes fades to grey abnormally and then restarts instead of shutting off. It will not shut off fully even no matter how long I hold down the power button.

Change History

Changed 7 years ago by jg

  • cc wad added
  • owner changed from jg to jfuhrer

John, what hardware?

Changed 7 years ago by jfuhrer

I've noticed this on B3s and B4s.

Changed 7 years ago by jg

  • cc mlj added; wad removed
  • owner changed from jfuhrer to wad
  • component changed from distro to hardware
  • milestone changed from Untriaged to CTest

Changed 7 years ago by jg

  • priority changed from high to blocker

Changed 7 years ago by jfuhrer

As it turns out, my B3 and B4 were reflashed to Q2Cd86 while I wasn't looking - apparently that's the source of this.

If that's expected behavior from Q2Cd86 then I'll just close this...

Changed 7 years ago by jg

  • cc wad, rsmith added

If this is expected, please close it out, wad or richard.

Changed 7 years ago by wad

jfuhrer,

If the behavior you are seeing is:

- Short press of the power button (less than three seconds) turns the screen off, but the power LED stays on. - Another short press turns the screen back on (it quickly resumes to sugar). - A long press (longer than six seconds) turns both the screen and power LED off.

This is expected behavior with more recent builds. The machine is being suspended and resumed using the power button.

Changed 7 years ago by jg

  • status changed from new to closed
  • resolution set to invalid

Note that since a resume may or may not succeed due to other bugs right now, (see #60), you may see non-deterministic behavior.

Wad's description, is, however, correct as to how it is supposed to work.

Note: See TracTickets for help on using tickets.