Opened 7 years ago

Closed 3 years ago

#2547 closed defect (fixed)

Build 537: TamTam fails to launch when datastore is writing changes

Reported by: Nat Owned by: Nat
Priority: high Milestone: 8.2.0 (was Update.2)
Component: tamtam-activity Version:
Keywords: Cc: philipmac1@…
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

The first time you launch TamTam, it loads fine.
The second time you load it, the icons keeps pulsating and nothing happens.
This is on a B4.

Attachments (2)

TamTam.log (14.0 KB) - added by jfuhrer 7 years ago.
datastore.log (1.2 KB) - added by jfuhrer 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by Nat

  • Summary changed from Build 537: TamTam fails to launch the second time to Build 537: TamTam fails to launch when datastore is writing changes

After some testing we found out the problem is that you need to wait a bit before restarting, if you start tamtam too quickly after a quit, it will fail, probably because the datastore is still writing the object.
Perhaps there should be a check before activities are launched to prevent loading until the datastore is done ?

comment:2 Changed 7 years ago by tomeu

some logs with the error that happens when you try to start the new one too quickly would be greatly appreciated.

comment:3 Changed 7 years ago by marco

  • Owner changed from marco to tomeu

Changed 7 years ago by jfuhrer

Changed 7 years ago by jfuhrer

comment:4 Changed 7 years ago by tomeu

Can you try again with 539? Cannot reproduce, although tamtam take a lot of time to start the second time.

comment:5 follow-up: Changed 7 years ago by jg

  • Milestone changed from Trial-2 to Trial-3
  • Owner changed from tomeu to Nat

comment:6 in reply to: ↑ 5 ; follow-up: Changed 7 years ago by ethrop

The problem seems to have gone away with build 540. We'll leave the trac up for a bit more systematic testing, but I think this one is fixed.

comment:7 in reply to: ↑ 6 Changed 7 years ago by philipmac

Replying to ethrop:

The problem seems to have gone away with build 540. We'll leave the trac up for a bit more systematic testing, but I think this one is fixed.

I have the issue of Tamtam not loading the second time in build 542

comment:8 Changed 7 years ago by philipmac

  • Cc philipmac1@… added

comment:9 Changed 7 years ago by kimquirk

  • Milestone changed from Trial-3 to First Deployment, V1.0

comment:10 Changed 7 years ago by kimquirk

  • Priority changed from blocker to high

comment:11 Changed 3 years ago by cjl

  • Action Needed set to never set
  • Resolution set to fixed
  • Status changed from new to closed

Closing as fixed

Note: See TracTickets for help on using tickets.