Opened 7 years ago

Closed 7 years ago

#2906 closed defect (fixed)

COW support in build kernels

Reported by: cscott Owned by: dilinger
Priority: normal Milestone: Not Triaged
Component: distro Version:
Keywords: Cc: mstone, bertl
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

mstone tells me that Copy-on-write support (which I would like to use in upgrades) requires git commit c53121c04317d23aa60664e08933218ef66f3ed6 from the vserver git. (git://dev.laptop.org/users/mstone/olpc-2.6). From IRC:

(02:40:52 PM) Ashsong_home: There are two fixes here, first the generic_sendpage() infrastructure that makes CoW work and the changes to olpc_defconfig that cause file permissions to be preserved across reboots on JFFS2.
(02:41:24 PM) Ashsong_home: but if he adds me as a remote and runs git-remote update, he should be able to just merge the stated commits and git will do the right thing. (git remote add git://dev.laptop.org/users/mstone/olpc-2.6)
(02:41:29 PM) Ashsong_home: We were trying to make this easy for him.
(02:42:37 PM) Ashsong_home: (Incidentally, I think he didn't commit those changes because he wanted Dave to review the generic_sendpage stuff).
(02:43:18 PM) Ashsong_home: I'm told that Dave and Herbert talked and that they agreed that since the sendpage patch was vserver-specific, Herbert was the appropriate judge of its correctness and that Andres should perform the merge.
(02:43:23 PM) Ashsong_home: However, that's just hearsay.

I need working COW to keep making progress on upgrades, which I'd like to get into the builds early this week.

Change History (4)

comment:1 Changed 7 years ago by dwmw2

  • Cc dwmw2 removed

comment:2 Changed 7 years ago by cscott

from IRC:

(03:09:16 PM) C. Scott Ananian: dwmw2_gone: for the purposes of the trac bug, all i was looking for was a quick "yes i don't care if this goes in" on record.
(03:09:40 PM) dwmw2_gone: cscott: Go ahead; I don't care a jot.
(03:09:46 PM) C. Scott Ananian: dwmw2_gone: thx

comment:3 Changed 7 years ago by cscott

Just to more completely document the issue, from IRC:

(03:03:09 PM) dwmw2_gone: cscott: please don't copy me on jffs2 bugs which aren't relevant to support{ed,able} kernels.

(03:05:40 PM) Ashsong_home: dwmw2_gone: I believe he cc'ed you just to make sure that we had correctly understood that you agreed that the Herbert was the right person to judge the correctness of the patch including a generic_sendpage method in the JFFS2 filesystem table.

(03:07:00 PM) Ashsong_home: dwmw2_gone: (Andres had asked for your opinion on the patch, and Herbert told me that the two of you had negotiated it, but I wasn't party to that conversation, so I felt I couldn't speak authoritatively to Andres on your behalf)

(03:07:09 PM) dwmw2_gone: I'll have said _I'm_ not interested unless it's in the context of upstream merging. Which isn't quite the same as what you said.

(03:07:44 PM) dwmw2_gone: we had a conversation a while ago which I don't remember very well. At the time, I didn't really think we were ever going to be that silly

(03:08:24 PM) dwmw2_gone: we have a (quick hack) fix for the ACL-related permissions problem which actually exists upstream

(03:08:33 PM) dwmw2_gone: without vserver, I cannot reproduce the other permissions problem

(03:09:11 PM) dwmw2_gone: although it's possible that it's a latent jffs2 bug -- which would want fixing anyway

(03:09:16 PM) C. Scott Ananian: dwmw2_gone: for the purposes of the trac bug, all i was looking for was a quick "yes i don't care if this goes in" on record.

(03:09:40 PM) dwmw2_gone: cscott: Go ahead; I don't care a jot.

(03:09:46 PM) C. Scott Ananian: dwmw2_gone: thx

(03:10:39 PM) Ashsong_home: dwmw2_gone: With respect to the permissions problem, we're content to just turn off POSIX ACLs.

(POSIX ACLs being libacl, not POSIX standard user/group/other permissions)

comment:4 Changed 7 years ago by dilinger

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.