Opened 10 years ago

Closed 10 years ago

Last modified 21 months ago

#3062 closed defect (fixed)

Etoys closed without saving

Reported by: bert Owned by: etoys
Priority: high Milestone:
Component: etoys-activity Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

When stopping etoys from the home view it does not save to the datastore. The VM needs to signal an event so the current project can be saved before quitting.

Can anybody confirm that Sugar is using the WM_DELETE_WINDOW protocol (http://tronche.com/gui/x/icccm/sec-4.html#s-4.2.8.1) to close an activity?

Change History (7)

comment:1 Changed 10 years ago by bert

VM part is implemented in svn, will be in next squeak-vm rpm. etoys code still needs to be adapted.

comment:2 Changed 10 years ago by bert

Change set 1574 adds handler support for the VM close event.

comment:3 Changed 10 years ago by jg

  • Milestone changed from Untriaged to Trial-3
  • Priority changed from normal to high

comment:4 follow-up: Changed 10 years ago by ohshima

It is almost working, but there is a glitch when Etoys trys to save a project implicitly when the project was loaded from Journal...

comment:5 in reply to: ↑ 4 Changed 10 years ago by bert

Replying to ohshima:

It is almost working, but there is a glitch when Etoys trys to save a project implicitly when the project was loaded from Journal...

Seems that "glitch" was caused by #3324.

comment:6 Changed 10 years ago by bert

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 21 months ago by Quozl

  • Milestone Trial-3 deleted

Milestone Trial-3 deleted

Note: See TracTickets for help on using tickets.