Ticket #3331 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

Xorg.conf isn't nuking lots of extensions...

Reported by: jg Owned by: bernie
Priority: high Milestone: 8.2.0 (was Update.2)
Component: distro Version:
Keywords: Cc: bernie
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

We once went through and got rid of many unneeded X extensions. These consume memory.

This seems to have hit the floor by accident with the changes to FC7. We can go to our old Xorg.conf file and figure out what changes are needed pretty trivially.

Change History

Changed 7 years ago by jg

  • owner changed from jg to J5

Changed 7 years ago by bernie

In Xorg 1.4, I disabled the bulkiest ones at compile time. Though maybe we can get rid of a few more.

Changed 7 years ago by jg

As I said, our old build (406.15) has an xorg file which gets rid of many of the non-compiled in extensions that get loaded.

That level change is nuking a few lines in the xorg.conf.

Changed 7 years ago by bernie

In 406.15 we loaded the following modules:

Section "Module"

Load "extmod" Load "freetype" Load "evdev"

EndSection

In latest builds, we also load type1 fbdevhw and record, all of which seem to be useless. I think it's save to turn them off.

xorg.conf also supports an "Extensions" section, but we never used it in our builds. For reference, this comes from my iBook's xorg.conf:

Section "Extensions"

Option "Composite" "Enable" Option "RENDER" "Enable" Option "XEVIE" "Disable"

EndSection

These are the extensions we load from extmod (can be disabled individually):

(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource

These are the the builtin extensions:

(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE

Changed 7 years ago by J5

fixed the Modules but which extention do we want and which do we throw away?

Changed 7 years ago by jg

I think you can likely nuke:

Extended-Visual-Information SECURITY XFree86Bigfont XFree86-DGA XFree86-Misc XFree85-VidModeExtension XINERAMA

Changed 6 years ago by jg

  • owner changed from J5 to bernie

Changed 6 years ago by bernie

  • status changed from new to closed
  • resolution set to duplicate

Dupe of #3715.

Note: See TracTickets for help on using tickets.