Opened 7 years ago

Closed 7 years ago

#3458 closed defect (fixed)

Connecting to a wireless router wasn't accepting the WPA password, until I removed and put back the battery

Reported by: HoboPrimate Owned by: dcbw
Priority: high Milestone: 8.2.0 (was Update.2)
Component: distro Version: Development build as of this date
Keywords: Cc: jcardona, marcelo, rchokshi, philipmac, dwmw2
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

I got a B4-8, with build 579. The first time I booted into it, I chose my network, gave it the password, and was successfully connected. After a reboot, It stopped working (the password dialog kept re-appearing).
I restarted, and shut off the laptop many times, but no luck.
Then I remembered to take out the battery and put it back in, and it worked :)

Here is some configuration on the router configuration (It's a sitecome 54G):

Mode:AP
Band:2.4 GHz (B+G)
Essid:sitecome
Channel number:11

Encryption:WPA pre-shared key
WPA Unicast Cipher Suite: WPA(TKIP)

Attachments (1)

messages (59.1 KB) - added by HoboPrimate 7 years ago.
/var/log/messages of the time the password wasn't being accepted

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by HoboPrimate

/var/log/messages of the time the password wasn't being accepted

comment:1 Changed 7 years ago by jg

  • Cc jcardona marcelo rchokshi added
  • Milestone changed from Untriaged to First Deployment, V1.0
  • Owner changed from jg to dcbw
  • Priority changed from normal to high

How did you shut off the laptop? Did you do a full reset of the CPU?

comment:2 Changed 7 years ago by HoboPrimate

Yes, I shutdown the laptop, unplug it, take out the battery, wait 30 seconds, then insert it back in. And this fix only works on the first boot after reinserting the battery. On the following boots, it happens again (until I do the reset again).

Forgot to say, the firmware is: CL1 Q2C26 Q2C

comment:3 Changed 7 years ago by HoboPrimate

  • Resolution set to fixed
  • Status changed from new to closed

This seems to be fixed now, when I upgraded to build 581.

comment:4 Changed 7 years ago by HoboPrimate

  • Resolution fixed deleted
  • Status changed from closed to reopened

Oops, sorry, my mistake, I thought I had rebooted at least once after running the new build, but didn't. So it still reacts like I mentioned.

comment:5 Changed 7 years ago by philipmac

  • Cc philipmac added

comment:6 Changed 7 years ago by HoboPrimate

Hi, now I think this was a problem with the router. I stopped being able to connect to it using a normal laptop the day before last. Yesterday it fixed itself in both the typical laptop and the XO, so I don't really understand what was the problem, but the culprit was definetly the router.

comment:7 Changed 7 years ago by philipmac

That's strange. Because I'm getting the problem you described above. I'm using wpa-psk on a D-Link DVG-G1402S and trying to connect with build 579, q2c26. It kept on asking for my password and the only way to fix it was to poweroff and remove the battery. Normal laptops connect to it perfectly and it's only the XO that has been having difficulty with it. #2803

comment:8 Changed 7 years ago by HoboPrimate

Indeed, I forgot to mention this. Try following these steps:

  1. Reboot XO without taking out the battery
  2. When getting back into Sugar, wait until the password dialog appears. Enter it, and it wil came back again, so Cancel it.
  3. Wait some seconds, then choose to disconnect from the router network icon on the Home View. 4 . Wait some seconds, go to mesh view, and click on the router network. It now doesn't ask a password and connects.

I don't know if those waiting seconds are necessary, haven't tried without them.

comment:9 Changed 7 years ago by HoboPrimate

I suggest that the operation I described on the previous comment be included in the Release Notes for trial-3 (if it also fixes philipmac problem).

comment:10 Changed 7 years ago by philipmac

I'm on build 611 now and wireless still isn't working properly. Sometimes it just connects properly and other times it doesn't. When it doesn't I enter the password after clicking on the circles and it just stays grey and flashes without connecting. The steps mentioned above don't work for me.

comment:11 Changed 7 years ago by HoboPrimate

Fimware q2c28 seemed to have totally fixed this problem to me.

comment:12 Changed 7 years ago by HoboPrimate

I've seen this behave one more time, with q2d04 firmware. After taking out the battery and putting it back in, the problem never appeared again.

comment:13 Changed 7 years ago by dwmw2

  • Cc dwmw2 added
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.