Ticket #3470 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Build 578/579/581 don't boot correctly in VMware and QEMU

Reported by: ant Owned by: J5
Priority: high Milestone: Trial-3
Component: distro Version: Development build as of this date
Keywords: Cc:
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Following the steps outlined on the wiki:  http://wiki.laptop.org/go/VMware, I have previously been able to boot up OLPC images in VMware Workstatation. These latest two builds boot and then say:

INIT: Id "x" respawning too fast: disabled for 5 minutes

I can hit enter and login as root. Trying to run /sbin/olpc-dm complains:

Segmentation fault

However, I can "startx."

I looked at inittab and id 'x' is for /sbin/olpc-dm

Not sure how to debug this, but it looks like something has been broken.

Change History

  Changed 7 years ago by jg

  • priority changed from blocker to high
  • milestone changed from Untriaged to First Deployment, V1.0

This is clearly not

  Changed 7 years ago by MitchellNCharity

QEMU is failing as well.

On first boot, instead of the sign-on screen, one gets:

OLPC build 581 (stream development...) Kernel ... <blank line> INIT: Id "x" respawning too fast: disabled for 5 minutes

With:

Build 581. QEMU PC emulator version 0.8.2 No kqemu. x86_64 fc6

I normally run (faster) with kqemu (can't at the moment), so I can't speak to how new the problem is.

  Changed 7 years ago by MitchellNCharity

  • priority changed from high to blocker
  • milestone changed from First Deployment, V1.0 to Untriaged
  • summary changed from Build 578/579 don't boot correctly in VMware Workstation to Build 578/579/581 don't boot correctly in VMware and QEMU

I am reverting jg's triage, changing Milestone to Untriaged, and Priority to blocker. And updating the summary.

To Untriaged because, with QEMU broken as well, the problem now looks like "all emulation is currently broken", rather than a VMWare-specific problem.

To Blocker, mostly just to make sure the change gets noticed. OLPC policy towards emulation has never been clear to me. While core team will sometimes spend time on it, emulation does not appear in roadmap milestones, or seemingly elsewhere as a project objective. While working emulation could greatly increase the size of our tester community, more than one person decided not to recruit emulation-based testers for Trial-3, given that emulation broke, and was left broken, in the run up to Trial-2. I realize this is just one facet of the OLPC "we are currently too busy to get help" problem. But perhaps given the stated need for greater testing (Walter's news summary last week), making emulation an objective might be decoupled from the general "we'll work to grow a development community when we finally have time, after FRS" solution. So "high" may be the right thing for now, but if FRS is to ship well tested, emulation may need to be made an objective.

  Changed 7 years ago by jg

  • priority changed from blocker to high
  • owner changed from jg to J5
  • milestone changed from Untriaged to Trial-3

Mitchel,

The point about VMware is that none of us run it. I agree that having qemu broken isn't good, which is in widespread use.

I still can't rate this as more than high: we certainly won't hold up MP for it.

It is certainly highly desirable for any stable build, however, which trial three will be.

in reply to: ↑ description   Changed 7 years ago by KraetziChriZ

Also the Image 577 is affected. Dont want test more images, because I want a NEW Image ;)

Replying to ant:

Following the steps outlined on the wiki:  http://wiki.laptop.org/go/VMware, I have previously been able to boot up OLPC images in VMware Workstatation. These latest two builds boot and then say: INIT: Id "x" respawning too fast: disabled for 5 minutes I can hit enter and login as root. Trying to run /sbin/olpc-dm complains: Segmentation fault However, I can "startx." I looked at inittab and id 'x' is for /sbin/olpc-dm Not sure how to debug this, but it looks like something has been broken.

  Changed 7 years ago by mihi

does not work in virtualbox either.

Here is a backtrace from qemu (if that helps):

Program received signal SIGSEGV, Segmentation fault. 0xb7e578fa in _IO_vfscanf_internal () from /lib/libc.so.6 (gdb) bt full #0 0xb7e578fa in _IO_vfscanf_internal () from /lib/libc.so.6 No symbol table info available. #1 0xb7e5d413 in vfscanf () from /lib/libc.so.6 No symbol table info available. #2 0xb7e624f2 in fscanf () from /lib/libc.so.6 No symbol table info available. #3 0x080494c5 in misc_conv () No symbol table info available. #4 0x08049af9 in misc_conv () No symbol table info available. #5 0x0804a2c6 in misc_conv () No symbol table info available. #6 0xb7e23f70 in libc_start_main () from /lib/libc.so.6 No symbol table info available. #7 0x080492d1 in misc_conv () No symbol table info available.

  Changed 7 years ago by J5

I figured this out and am building a fix which should see the next release as I consider this critical. For now you can "fix" the issue by running this command as root:

touch /etc/sysconfig/i18n

  Changed 7 years ago by ant

  • status changed from new to closed
  • resolution set to fixed

I have verified that build 593 runs in VMware workstation. The last person to verify QEMU/VirtualBox, please check the verify box. Thanks all!

Note: See TracTickets for help on using tickets.