Ticket #3610 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

Mystery shutdown without red warning LED

Reported by: MitchellNCharity Owned by: rsmith
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: hardware Version:
Keywords: Cc: wad, rsmith
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

B4 581 q2c26 NiMH A B4 shutdown unexpectedly. Neither I or the user recalled seeing the red battery LED lit before hand. Pressing the power button caused the screen to briefly light up before immediately turning off. Plugging in AC and pressing power worked. Battery was shown as low. I don't know how low. I don't know if it was a clean shutdown or just a quick power off. I had was talking with someone else, looked back, and the user had a dead machine.

It may just be observer error. Or perhaps it might be related to #436 and #2597. #2190 looks different, as no battery removal was needed to power on.

Change History

  Changed 7 years ago by jg

  • cc wad, rsmith added
  • milestone changed from Untriaged to MP Start

  Changed 7 years ago by MitchellNCharity

616 q2c28 B4.

Shutdowns where no-one remembers seeing the red light have occurred a couple more times over the last three weeks, but not with any greater certainty. I still can't say "this is definitely happening". But now it's clear the xo can be turned on with a very low battery, and run for several seconds without showing a red light.

I had been demoing the box, walked a block, and noticed I was now off. Backlight had been on medium to high. Was in home view, with Write, Record, and TamTamMini (silent) in the ring. It seemed like yet another occurance, because I hadn't noticed the red light. But as usual, it was possible I simply hadn't noticed.

But a few minutes later, I turned on the xo. and made it most of the way through a boot, before dieing, _without the red light on_. Moments later pressed the power button again. Didn't get very far, just barely into boot cruft scrolling by, but again, no red light. Third press didn't do more than flash, but still, no red light. Plugged in AC, orange light. Powered on, unplugged AC, red light. Repeated AC in-out a few times. Still normal.

Nothing in this followup testing seems odd, but I'll leave it for completeness. Charged up a bit (12%), drained until it turned off. Powered on, flashed and off. Again. No red light either time. Third time, got red light, and into ofw boot. Manually powered off. Forth time, again got red light, got to X startup before machine turned off. Fifth time, screen flash only, no red. Sixth time, again. Next two times, no flash, just green power light on for about a second. Next time power light went off immediately. It looks like the red light occurs after the flash but before the ofw screen shows up, so this all seems plausible. The only oddity is that there was no pause between the 2nd and third power on, and yet one flashed, and one made it into ofw boot (when I powered off). There was a longer pause between 3 and 4, as I took notes, so the long run in 4 makes sense.

See also #4052.

follow-up: ↓ 4   Changed 7 years ago by kimquirk

  • priority changed from normal to blocker
  • milestone changed from MP Start to First Deployment, V1.0

Turns out there is a problem with the updating of battery information, and so today (build 616), laptops without a power adapter will just fail without indication. This is a blocker for FRS.

Some other bugs of interest: #4208, #2861, #4052

in reply to: ↑ 3   Changed 7 years ago by rsmith

Replying to kimquirk:

Turns out there is a problem with the updating of battery information, and so today (build 616), laptops without a power adapter will just fail without indication. This is a blocker for FRS.

EC is what sets the light red. Regardless of what sugar is doing the battery light should have gone red.

The firmware here appears to be q2c28. Since that release I have re-worked some of the EC led code to fix a bug where the red light would not blink on error.

This fix in in q2c28i.rom (or greater. 'j' is the latest at the moment) which can be found in http:// dev.laptop.org/~wmb

Its seems to work correctly for me. Please re-test using the latest firmware.

Note: There is a period of about 3 or 4 seconds when you first insert a battery until the BMS system as a good "feel" for the battery being low or not. So if have a XO that is totally unpowered, you insert a low battery, and press the power button, then the XO will be several seconds in to the boot before the light turns red.

  Changed 7 years ago by rsmith

  • owner changed from mlj to rsmith

  Changed 6 years ago by rsmith

  • status changed from new to closed
  • next_action set to never set
  • resolution set to duplicate

see #5858

Note: See TracTickets for help on using tickets.