Ticket #3902 (closed defect: worksforme)

Opened 7 years ago

Last modified 6 years ago

Wi-fi causes extreme unresponsiveness

Reported by: ssb22 Owned by: AlexL
Priority: high Milestone: 8.2.0 (was Update.2)
Component: wireless Version:
Keywords: Cc: javier@…, luisca@…, mbletsas@…, GR-Wireless-OLPC@…, marcelo, rsmith, rchokshi
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

I am on Build 605 and I found that iwconfig and ifconfig commands can take several minutes to respond, during which time the XO is extremely unresponsive while it flashes its keyhole light incessantly and occasionally prints messages like

olpc-ec: timeout waiting for EC to quiesce! Failed to clear SCI queue!

(I'm not sure if that's related to wi-fi or not.)

This is when attempting to get it to connect to an ad-hoc wi-fi network, because I wasn't near an access point but I did have access to a Windows laptop with a wi-fi card that I could run in ad-hoc mode and hopefully provide Internet access to the XO that way, but I couldn't get it to work.

Change History

  Changed 7 years ago by ssb22

The same machine worked fine when I took it to an access point, so perhaps the problem occurs only if there is a machine in ad-hoc mode nearby.

  Changed 7 years ago by jg

  • cc javier@…, luisca@…, mbletsas@…, GR-Wireless-OLPC@…, marcelo, rsmith added
  • owner changed from jg to AlexL
  • priority changed from normal to high
  • component changed from distro to wireless
  • milestone changed from Never Assigned to First Deployment, V1.0

Alex, can you reproduce this problem?

  Changed 7 years ago by ssb22

Just now I was on the same XO, in an area that supposedly had free wi-fi; I clicked on one access point and nothing happened (no network), then I clicked on another which had WEP and it prompted for a password which I didn't have. Then the XO started banging the keyhole light incessantly and taking 100% CPU and becoming unresponsive, again. So apparently it's not just adhoc-only networks that can bring this on; it's also any Wi-Fi situation that the code wasn't expecting.

  Changed 7 years ago by rchokshi

What was the WiFi firmware version during this test?

  Changed 7 years ago by ssb22

I'm not sure how to find out the WiFi firmware version, but the firmware version I'm running is Q2C26 (on a B4 machine).

  Changed 7 years ago by AlexL

To find the wireless firmware version go to a terminal on the XO and type:

ethtool -i eth0

  Changed 7 years ago by ssb22

driver: libertas version: COMM-USB8388-322.pl-dbg firmware-version: 5.110.17.p3 bus-info:

  Changed 7 years ago by rchokshi

Can you please use one of the firmware releases that is posted on:

http://www.laptop.org/teamwiki/index.php/Tech:FW_8388_RELEASE_NOTES

and re-test.

5.110.18.p2 being the latest.

  Changed 7 years ago by rchokshi

  • cc rchokshi added

follow-up: ↓ 11   Changed 7 years ago by ssb22

When I try to go to that URL, I get "login required" even though I have created an account (user ID ssb22) and requested access. Can someone please either give me access or copy the relevant information to here (or mail me or whatever)?

NB this machine is due to be sent back for failure analysis anyway due to #3954 and #3948. I wonder if it's worth including this ticket (#3902) in that as well?

in reply to: ↑ 10   Changed 7 years ago by ashish

Replying to ssb22:

When I try to go to that URL, I get "login required" even though I have created an account (user ID ssb22) and requested access. Can someone please either give me access or copy the relevant information to here (or mail me or whatever)? NB this machine is due to be sent back for failure analysis anyway due to #3954 and #3948. I wonder if it's worth including this ticket (#3902) in that as well?

The wireless firmware release 5.110.19.p5 will be having some fixes that should fix this problem. Could you provide more information on howto reproduce this if you observe this on 5.110.19p5 wireless firmware release?

  Changed 7 years ago by ssb22

How do I install wireless firmware release 5.110.19.p5? I assume the answer is on the wiki page that was linked to earlier in this thread, but (as I said) I don't have access to that page. Thanks.

  Changed 7 years ago by ashish

This version is not yet released.

  Changed 7 years ago by AlexL

I believe the latest version available right now is 19.p0. The releases are located at http://dev.laptop.org/pub/firmware/libertas/

to install new wireless, see http://wiki.laptop.org/go/Test_Config_Notes#Update_the_wireless_firmware

the public file is the .bin file, so you don't need to do the unzipping or anything. Just rename the file, and replace the old one.

  Changed 6 years ago by kimquirk

  • status changed from new to closed
  • resolution set to worksforme

Closing this bug as it has no longer seen. If it shows up again, please re-open or start a new bug.

Note: See TracTickets for help on using tickets.