Ticket #4009 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

My XO is friends with itself

Reported by: cscott Owned by: cscott
Priority: high Milestone: 8.2.0 (was Update.2)
Component: presence-service Version:
Keywords: fixed? Cc: Collabora
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

In the mesh view, my XO always displays a friend with my name, even if no XOs are around.

Well, not exactly. I named my XO, "C. Scôtt Ananian" (note that accent on the o), and I get a friend on mesh view named "C. Scott Ananian" (note, no accent). I suspect that the mesh presence protocol is incorrectly stripping accents at some point, causing the XO not to recognize itself when seen in the mirror.

Change History

  Changed 7 years ago by marco

  • owner changed from marco to morgs
  • component changed from sugar to presence-service

Sounds like a PS issue. (I assume this is an additional XO, other than the icon we display in the center which is wanted behavior).

  Changed 7 years ago by cscott

Yes, this is an additional XO, not the center one. I agree it's presence-service. I didn't know the components well enough to assign it properly, sorry.

  Changed 7 years ago by jg

  • milestone changed from Never Assigned to First Deployment, V1.0

  Changed 7 years ago by kimquirk

  • priority changed from normal to high

  Changed 7 years ago by daf

Should be pretty easy to reproduce. Perhaps something to do with the way PS compares strings?

  Changed 7 years ago by morgs

  • cc morgs, smcv added

smcv: Could your fix for #3683 be relevant to this too?

  Changed 7 years ago by smcv

Presence Service doesn't compare strings, it compares Telepathy handles. In Gabble these represent JIDs (public-key hashes, basically) on the server, so people are never compared by name. In Salut handles represent _presence._tcp service names; in versions where #3683 still exists, these are derived from the nickname and the .local hostname, and in versions where that bug has been fixed they're based on the public-key hash and the .local hostname. So there's no approximate comparison, and no assumption that nicknames are a unique identifier, in PS.

As always, the PS tab in the devel console will tell you what the PS is thinking. If that's right, but the neighbourhood view is wrong, then it's Sugar's fault; if both are wrong, it's PS's fault.

I tried setting my jhbuild's nickname to "SMcV (with a ô to test #4009)" and I don't see this problem...

  Changed 7 years ago by smcv

cscott, if you can reproduce this, could you provide us with some more details?

* Is this a real XO, or a jhbuild? If a real XO, which image version?

* Are you using link-local or server-based collaboration? (i.e.: can you see the Internet on the offending XO?)

* What does the Presence tab in the devel console say? Do you get two entries for yourself in the Contacts pane, or just one? It'd be great if you could transcribe all the Contacts rows that look like they refer to you

* Can you enable debug and get us some logs? (If running on a real XO, uncomment the line in ~/.xinitrc that sources .sugar.debug)

follow-up: ↓ 10   Changed 7 years ago by cscott

Last time I saw this it was on a real XO, and I was using link-local collaboration. No access points for a couple of miles.

I'd suggest the sugar developers get in the habit of using "funny characters" in their XO's name. This isn't the first time I've seen bugs which are related to this.

I'll update this bug if/when I see it again, and attach the logs.

in reply to: ↑ 9   Changed 7 years ago by AlbertCahalan

Replying to cscott:

I'd suggest the sugar developers get in the habit of using "funny characters" in their XO's name. This isn't the first time I've seen bugs which are related to this.

The kid could choose a name like this...

http://xkcd.com/327/

Fun: special XML characters, illegal UTF-8, percent followed by "n", and any of the preceeding with various escape-like encodings.

  Changed 7 years ago by smcv

While I'm aware that this is a concern, I'm pretty sure that we never use the user-supplied nickname as an account name, and we always compare by either account name or public-key hash (in practice, the account name *is* the public key hash).

Until #3683 was fixed, the user-supplied nickname was used to distinguish between accounts on the same machine. It's possible that this is somehow connected.

  Changed 7 years ago by daf

  • cc daf added

It's not clear to me whether this bug can be reproduced in recent builds. If we can't reproduce it, we should close it.

  Changed 7 years ago by daf

Scott, if you can reproduce this, you might be able to get some more information using the Presence Service debugger in the Analyze activity.

  Changed 7 years ago by cscott

I believe that #4518 is a reflection of the same underlying problem.

It may have been that #3683 was involved, though, as my laptop's were usually named something like "C. Scott Ananian" (except with various random accents on the letters).

  Changed 7 years ago by smcv

  • keywords fixed? added

#4518 and #3683 have been fixed in Joyride and I've never been able to reproduce this particular bug, so I suspect this has been fixed too.

I've been using long nicknames that contain non-ASCII in order to test #4518, and I've never seen spurious buddies in the mesh view.

  Changed 7 years ago by gdesmott

  • cc gdesmott added

  Changed 7 years ago by gdesmott

  • owner changed from morgs to cscott

cscott could you retry to reproduce this bug with latest build please?

  Changed 7 years ago by cscott

Retried with ship.2 build 646, with jabber server set to ship2.jabber.laptop.org (a nonexistent machine). Name is 'C. Scott Ananian' with a dot under the o and a tilde on the second n.

Connected to an access point. One friend shows up, "C. Scott Ananian" -- no accents and in different colors. This friend goes away when I connect to a simple mesh (again, with no other XOs around).

  Changed 7 years ago by smcv

Sorry to sound like a broken record, but... logs, please? At least Shell, Presence Service and telepathy-salut.

  Changed 7 years ago by smcv

(I have a vague theory why this might have been different between real XOs and my testing in sugar-jhbuild - real XOs seem to enter accented characters as base + combining character, while all the accented names I got into jhbuild were pre-composed. Normalization Form D vs Normalization Form C. The most interesting thing in the logs will be to see which layer of the stack changes the name.)

  Changed 7 years ago by morgs

  • cc Collabora added; morgs, smcv, daf, gdesmott removed

I think this might have been caused by the same problem as #5573. See the patch: http://dev.laptop.org/attachment/ticket/5573/friend.patch

While this is marked Update.2, it would be nice to resolve this if it has been fixed.

  Changed 6 years ago by marco

  • status changed from new to closed
  • resolution set to duplicate
Note: See TracTickets for help on using tickets.