Opened 7 years ago

Closed 3 years ago

#4153 closed defect (fixed)

connect to linklocal instead of schoolmesh

Reported by: yani Owned by: joe
Priority: high Milestone: 8.2.0 (was Update.2)
Component: network manager Version:
Keywords: 8.2.0:? Cc: jg, kimquirk, dcbw, mstone, wad, mbletsas, joe, Gregorio
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: yes

Description

It happens very often that you click on channel 1 to connect to schoolserver, but instead it connects to link local on channel one.

You have an 169.254.x.x ip, and the resolv.conf is empty

612
Q2C27m

Attachments (1)

messages (68.1 KB) - added by yani 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by yani

comment:1 Changed 7 years ago by jg

  • Milestone changed from Never Assigned to First Deployment, V1.0

comment:2 Changed 7 years ago by kimquirk

  • Cc jg kimquirk added
  • Priority changed from normal to high

comment:3 Changed 7 years ago by kimquirk

  • Keywords killjoy? added

Here is a use case to think about: a number of students near a school server open their laptops and will automatically connect to the school server mesh. If they want to limit their networking to the classroom or a smaller group, they could force a local-link mesh (any of 3 channels).

But today, if their school server is using all 3 mesh channels, then when they click on 'Mesh X', they will get the school server, not the local link. Seems like they should be able to choose between those two options.

Most likely this should be documented in the release note for XM; and moved out to a later release -- but it might be good for someone to evaluate the work effort needed.

comment:4 Changed 7 years ago by wad

  • Cc dcbw added
  • Keywords WLAN school server added; killjoy? removed
  • Verified set

This was reported more recently as #5963, which has been closed as a duplicate of this ticket.

comment:5 Changed 7 years ago by Blaketh

  • Keywords release? added

comment:6 Changed 6 years ago by gregorio

  • Action Needed set to test in build
  • Cc mstone wad mbletsas joe Gregorio added
  • Keywords 8.2.0:? added; WLAN school server release? removed

Is this reproducible in joyride? (I suspect that it will be, but we'd better check.)

comment:7 Changed 6 years ago by joe

  • Owner changed from dcbw to Charlie

Charlie,

When you have a chance to test a Joyride in the school server environment, please try to retest this one.

Joe

comment:8 Changed 6 years ago by Charlie

  • Owner changed from Charlie to joe

comment:9 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

School server mesh mode is not supported in XS 0.7, and has not been officially recommended or used to any extent I know of for quite some time.

Note: See TracTickets for help on using tickets.