Opened 8 years ago

Closed 7 years ago

#417 closed defect (fixed)

abiword doesn't render arabic.

Reported by: warp Owned by: behdad
Priority: high Milestone: Update.1
Component: write-activity (abiword) Version:
Keywords: relnote Cc: khaled
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

When we get arabic characters under abiword we get those lovely characters with the character code in it.

It's a nice way to show unknown characters, but somehow I don't think it's all that useful for reading arabic.

Change History (28)

comment:1 Changed 8 years ago by uwog

This _might_ be fixed when I merge the AbiWord Sugar branch into CVS HEAD: CVS HEAD has way better pango support.

comment:2 Changed 8 years ago by jg

  • Keywords relnote added
  • Milestone changed from BTest-1 to BTest-2
  • Priority changed from normal to high

Obviously, we're not going to do this before BTest-1.

comment:3 Changed 8 years ago by jg

Please do *not* try to do this for B1B; leave until afterwords, for the BTest2 system.

comment:4 Changed 8 years ago by msevior

warp, can you try arabic with the current jh-build of Abiword? It should render Arabic now.

comment:5 Changed 8 years ago by jg

  • Owner changed from blizzard to msevior

Msevior; if this works for you, please close this out.

comment:6 Changed 8 years ago by khassounah

Build 239 update: Still doesn't work

comment:7 follow-up: Changed 8 years ago by khassounah

the problem is default font. If you change the font (ctrl+D) to one that has the Arabic character set, you can enter arabic text.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 8 years ago by msevior

Replying to khassounah:

the problem is default font. If you change the font (ctrl+D) to one that has the Arabic character set, you can enter arabic text.

What fonts have good Arabic coverage? We can change things based on the LANG environment variable or set a default template for Arabic builds with the right font.

Apart from the font is the rendering OK? Please report detailed bugs to the abiword mailing list.

comment:9 in reply to: ↑ 8 Changed 8 years ago by khassounah

Replying to msevior:

Replying to khassounah:

the problem is default font. If you change the font (ctrl+D) to one that has the Arabic character set, you can enter arabic text.

What fonts have good Arabic coverage? We can change things based on the LANG environment variable or set a default template for Arabic builds with the right font.

You can use any of the KACST fonts, I would recommend the "KACST One" font.

Apart from the font is the rendering OK? Please report detailed bugs to the abiword mailing list.

As stated above, when an appropriate font is selected, there are no issues (i.e. renders correctly).

Which abiword mailing list? isn't it better if we all use the same system to report and track bugs?

comment:10 follow-up: Changed 8 years ago by jg

Are you using Pango in abiword these days? It can handle, using fontconfig, figuring out which fonts are needed to cover what languages... I would hope abiword, even if it uses its own layout engine, could do likewise.

Having to manually find fonts with specific language coverage is so '80s ;-). We dragged X kicking and screaming into proper font support early in this millenium....

comment:11 Changed 8 years ago by jg

  • Milestone changed from BTest-2 to BTest-3

comment:12 Changed 8 years ago by msevior

That would be the abiword mailing list:

abiword-dev@…

This is a bug in the upstream version of abiword and needs to be fixed there. As a word processor we normally honour a users choice of font. Tomas Frydrych is looking into solving this with auto substitution.

comment:13 Changed 8 years ago by msevior

Tomas asks that you post a sample Arabic document to test.

comment:14 Changed 8 years ago by jg

  • Cc khassounah added
  • Component changed from distro to abiword

are you suggesting that we complain upstream? I'm sure Khaled would be happy to ;-).

Fontconfig is your friend, when it comes to font substitution and computing language coverage.

comment:15 Changed 8 years ago by msevior

Of course! Please do complain upstream. This is exactly the kind of feedback we want and need. I've passed on the existance of this bug to Tomas, our pango and complex text rendering expert but it makes much more sense for Kahled to provide feedback directly to Tomas.

He is very motivtaed and wants this to work but is limited through lack of feedback for languages with which he is unfamiliar.

comment:16 in reply to: ↑ 10 Changed 8 years ago by tf

Having to manually find fonts with specific language coverage is so '80s ;-).
We dragged X kicking and screaming into proper font support early in this millenium....

You seem to have forgotten what the 80's were like -- when this millenium arrived unices were still using 8-bit locales as a matter of course, and AbiWord, which was using Unicode from day one, was jumping through hoops to work around the limitations (and still is). ;-)

Since support for complex scripts matters to the OLPC, you might want to find someone to work on Pango to get it up to scratch -- Pango is still missing the ability to do justification, which no self-respecting complex script processor can be without (Behdad does an excellent job, but there is only so much any single person can do).

Anyway, I have made what I think are the necessary changes upstream.

comment:17 Changed 8 years ago by jg

I remember all too well, both the '80's (and blame for X's broken core fonts can clearly be laid partially at my feet), and the more recent history....

Suggestions as to whom? People with a deep understanding of I18N are hard to find...

Thanks for all your help!

comment:18 follow-up: Changed 8 years ago by marco

What is the status of this one?

comment:19 in reply to: ↑ 18 Changed 8 years ago by msevior

Replying to marco:

What is the status of this one?

I believe this is fixed but it should be tested by an Arabic speaker/writer.

comment:20 Changed 8 years ago by jg

  • Owner changed from msevior to behdad

Behdad, could you take a second and confirm this is fixed?

Thanks, - Jim

comment:21 Changed 8 years ago by behdad

haha. Pango does justification now:

http://mces.blogspot.com/2007/05/justified-text-with-pango.html

I'll test this bug when I get home later tonight. Is the latest devel build enough to test it?

comment:22 Changed 8 years ago by jg

Yes, the abiword fixes for Arabic went in a long time ago: they have just never been verified on our system by anyone who can read arabic.

comment:23 Changed 7 years ago by kimquirk

  • Milestone changed from BTest-4 to Trial-2
  • Verified unset

Moving to next software release, Trial-2.

comment:24 Changed 7 years ago by jg

  • Cc khaled added; khassounah removed
  • Milestone changed from Trial-2 to Trial-3

Behdad, Khaled, how are recent builds?

Fixing this for Trial-2 seems unlikely if it isn't already fixed, but I thought I'd ask...

comment:25 Changed 7 years ago by khaled

As far as I can tell, this doesn't seem to happen any more, but we still have #2207 which might or might not be related to this one.

comment:26 Changed 7 years ago by jg

Khaled, how are current builds?

comment:27 Changed 7 years ago by uwog

  • Milestone changed from Trial-3 to First Deployment, V1.0

comment:28 Changed 7 years ago by uwog

  • Resolution set to fixed
  • Status changed from new to closed

Closing this one per khaled's comment; moving the rest of this issue to 2207

Note: See TracTickets for help on using tickets.