Opened 7 years ago

Closed 6 years ago

#4208 closed defect (fixed)

Battery indicator's icon fullness inconsistent with indicator %.

Reported by: MitchellNCharity Owned by: mtd
Priority: high Milestone: 8.2.0 (was Update.2)
Component: sugar Version: Development build as of this date
Keywords: joyride-2201:+ Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: finalize
Verified: no

Description

616 q2c28 B4.
The Home view battery icon was completely full, while its hover pop-down said 85%. This discrepancy persisted through AC un/plugged cycles.

This seems a new issue, distinct from #2861.

Change History (12)

comment:1 Changed 7 years ago by jg

  • Milestone changed from Never Assigned to First Deployment, V1.0
  • Priority changed from normal to high


comment:2 Changed 6 years ago by marco

  • Keywords 8.2.0:? needs-testing added

comment:3 Changed 6 years ago by marco

  • Action Needed set to diagnose

comment:4 Changed 6 years ago by mtd

Dupe of / related to #4204?

comment:5 Changed 6 years ago by marco

  • Owner changed from marco to mtd

comment:6 Changed 6 years ago by mtd

  • Action Needed changed from diagnose to code
  • Keywords r? added; needs-testing removed
  • Version set to Development build as of this date

comment:7 Changed 6 years ago by marco

  • Keywords r+ added; r? removed

Style nitpick, no need to split the get_icon_state argument, it fits in 80 cols. Please make sure to test it before commiting.

comment:8 Changed 6 years ago by mtd

Tested - it works :). Though the difference between (even) 80% and 100% can be quite hard to discern.

comment:9 Changed 6 years ago by mtd

  • Action Needed changed from code to add to build

Pushed to sugar and sugar-toolkit.

comment:10 Changed 6 years ago by mtd

  • Action Needed changed from add to build to test in build

comment:11 Changed 6 years ago by erikos

  • Action Needed changed from test in build to finalize
  • Keywords joyride-2201:+ added; 8.2.0:? r+ removed

That works fine.

comment:12 Changed 6 years ago by gregorio

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.