Ticket #4264 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Build system should allow to make src/devel/debuginfo available

Reported by: marco Owned by: cscott
Priority: high Milestone: 8.2.0 (was Update.2)
Component: distro Version:
Keywords: blocks-:8.2.0 Cc: cjb, mstone, mako, gnu, dsd
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

I'm not sure what's the best way to do it but src, devel, and debuginfo for all the packages which goes on the images should be made available for download somewhere (ideally into a yum repository). They are essential for debugging and development.

Change History

  Changed 7 years ago by cjb

They are essential for debugging and development.

And GPL compliance. :)

follow-up: ↓ 5   Changed 7 years ago by cscott

The raw repos which the current joyride images are built from are available in git, in the users/cscott/repos module on dev. Currently I have to push to that git periodically from the build machine, but I intend to eventually have that done as a cronjob pull from dev.

If you put the src, devel, debug etc rpms into the public_rpms repository, they will show up in the gitted repo. I believe bernie is doing this already with the X packages.

  Changed 7 years ago by jg

  • cc mako added
  • milestone changed from Never Assigned to First Deployment, V1.0

  Changed 7 years ago by gnu

  • cc gnu added

in reply to: ↑ 2   Changed 7 years ago by bernie

Replying to cscott:

If you put the src, devel, debug etc rpms into the public_rpms repository, they will show up in the gitted repo. I believe bernie is doing this already with the X packages.

My public_rpms always has been a complete yum repo, fedora style:

http://codewiz.org/pub/olpc-bernie/

  Changed 6 years ago by gnu

  • keywords blocks?:8.2.0 added
  • next_action set to never set

yum in joyride-2263 does not know how to install glib2-debuginfo; and after doing "yum install yum-utils", doing "debuginfo-install glib2" does not work either. This is still broken! How will anyone debug anything in the field?

  Changed 6 years ago by gnu

By trolling around the web, I discovered that the relevant debuginfo file is here:

http://download.fedora.redhat.com/pub/fedora/linux/updates/9/i386/debug/glib2-debuginfo-2.16.5-1.fc9.i386.rpm

(OLPC pulled this package not from the main F9 release repository, but from the F9 updates that occurred since the release. In general, users will have no way to tell whether a package comes from the main repository or the updates -- or from an OLPC repository. They'll apparently have to enable all the repositories to find the right debug packages.)

This "ought to" be brought in by yum when --enable-repo=updates-debug is set, or the "enabled=0" in /etc/yum.repos.d/fedora-updates.repo is set to 1. But instead it gets an error:

Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates-debuginfo. Please verify its path and try again

Aha! This is because yum gets a $releasever of "8.93", probably because /etc/fedora-release says "OLPC release 8.93 (Joyride)". This is substituted into the pathnames in /etc/yum.repos.d/* and most of them don't work any more -- because the right $releasever is "9" for Fedora 9.

When I uncomment the "baseurl" line under the updates-debuginfo clause, and replace "$releasever" with 9, then it works. If I recomment the "baseurl" line and also fix the "$releasever" in the mirrors line, then it also works.

The problem is that Yum doesn't know how to deal with a situation where it's pulling files from two different release numbers: an OLPC release and a Fedora release.

The cure, I think, is to hardcode the Fedora release number in each line in /etc/yum.repos.d that refers to a Fedora release: sed 's/${releasever}/9/g' on each Fedora repo description.

  Changed 6 years ago by gregorio

  • cc dsd added
  • keywords blocks-:8.2.0 added; blocks?:8.2.0 removed

Hi Marco and team,

I'd like to do this right but I don't think I can hold the release for it.

I added Denis in case he can help.

Thanks,

Greg S

  Changed 6 years ago by gnu

#7398 is another report like this (about the broken $releasever in the joyride yum config).

  Changed 6 years ago by cscott

Fixing /etc/fedora-release seems to fix the problem. This change has been made in the 8.2 stream; please test 8.2-753 and later.

  Changed 6 years ago by cscott

  • status changed from new to closed
  • resolution set to fixed

Should be fixed.

Note: See TracTickets for help on using tickets.