Opened 7 years ago

Closed 4 years ago

#4449 closed defect (duplicate)

Kernel crash upon resume due to memory corruption

Reported by: wad Owned by: wad
Priority: high Milestone: 8.2.0 (was Update.2)
Component: hardware Version: 1.0-hardware-C
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

When doing a large number of suspend/resume cycles (tens of thousands), we occasionally see a kernel crash upon resume.

After filtering out the kernel crashes due to actual kernel bugs, we are left with a number of crashes which appear due to hardware problems, specifically memory corruption.

This seems to favor certain laptops, and is not seen on all machines. There is a special version of OFW (q2d01a) which implements a comparison of memory before and after the resume. It may be used to test specifically for this case.

Change History (2)

comment:1 Changed 7 years ago by wad

Trac #4459 is a duplicate of this, where the corruption was caught and reported by q2d01a. It includes kernel logs from the crashing laptop.

comment:2 Changed 4 years ago by wad

  • Action Needed set to never set
  • Resolution set to duplicate
  • Status changed from new to closed

This was almost certainly a side effect of #1835.

Closing out as a duplicate (and fixed!)

Note: See TracTickets for help on using tickets.