Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#4459 closed defect (duplicate)

Crashed into OFW while doing suspend resume testing

Reported by: AlexL Owned by: mlj
Priority: high Milestone:
Component: hardware Version:
Keywords: Cc: AlexL, wad, cjb
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

build 581 q2d01a, wireless firmware 19.p16 (from doing ethtool -i eth0)

The laptop was left, doing the suspend resume testing overnight. This is where a script is run, which continually puts the laptops in suspend, and a pinger wakes them up.

When I came in in the morning, the laptop was sitting in the OFW screen with the message "Interacting due to botched resume" in red, followed by the "ok" prompt.

I assigned this to Mitch Bradley, since it has to do with open firmware, and he probably has a better idea of who it should be assigned to.

Here are the last 100 lines from the log (off of the serial port)

[ 1.638604] Geode LX AES 0000:00:01.2: resuming
[ 1.659868] CAFÉ NAND 0000:00:0c.0: resuming
[ 1.681177] sdhci 0000:00:0c.1: resuming
[ 1.708841] PM: Writing back config space on device 0000:00:0c.1 at offset f (was 8080100, writing 808010b)
[ 1.754616] PM: Writing back config space on device 0000:00:0c.1 at offset 3 (was 800000, writing 802000)
[ 1.802836] PM: Writing back config space on device 0000:00:0c.1 at offset 1 (was 2b00002, writing 2b00006)
[ 1.854050] cafe1000-ccic 0000:00:0c.2: resuming
[ 1.883811] PM: Writing back config space on device 0000:00:0c.2 at offset f (was 8080100, writing 808010b)
[ 1.939682] PM: Writing back config space on device 0000:00:0c.2 at offset 3 (was 800000, writing 802000)
[ 1.996090] PM: Writing back config space on device 0000:00:0c.2 at offset 1 (was 2b00002, writing 2b00006)
[ 2.060588] pci 0000:00:0f.0: resuming
[ 2.089468] cs5535audio 0000:00:0f.3: resuming
[ 2.119222] PCI: Setting latency timer of device 0000:00:0f.3 to 64
[ 2.155783] ohci_hcd 0000:00:0f.4: resuming
[ 2.199959] PCI: Setting latency timer of device 0000:00:0f.4 to 64
[ 2.260087] ehci_hcd 0000:00:0f.5: resuming
[ 2.298088] PCI: Setting latency timer of device 0000:00:0f.5 to 64
[ 2.331814] usb usb1: root hub lost power or was reset
[ 2.364544] PCI: cache line size of 32 is not supported by device 0000:00:0f.5
[ 2.459283] serial8250 serial8250.0: resuming
[ 2.492004] platform pcspkr: resuming
[ 2.523964] platform vesafb.0: resuming
[ 3.610679] USB_REQ_SET_CONFIGURATION!
[ 3.644570] PM: Removing info for No Bus:usbdev1.2_ep02
[ 3.679286] PM: Removing info for No Bus:usbdev1.2_ep83
[ 3.713772] PM: Adding info for No Bus:usbdev1.2_ep02
[ 3.746886] PM: Adding info for No Bus:usbdev1.2_ep83
[ 3.781582] usb8xxx 1-1:1.0: resuming
[ 3.811484] i8042 i8042: resuming
[ 3.852335] atkbd serio0: resuming
[ 3.880353] psmouse serio1: resuming
[ 3.971850] OLPC-DCON 1-000d: resuming
[ 4.020438] platform dcon: resuming
[ 4.047385] olpc-dcon: The CPU has control
[ 4.073946] platform olpc-battery.0: resuming
[ 4.100131] ac97 0-0:AD1888: resuming
[ 4.124907] Restarting tasks ... done.
[ 4.336559] PM: Preparing system for mem sleep
[ 4.364872] Stopping tasks ... done.
[ 4.392145] ac97 0-0:AD1888: suspend
[ 4.415540] platform olpc-battery.0: suspend
[ 4.439490] platform dcon: suspend
[ 4.462091] OLPC-DCON 1-000d: suspend
+r[ 1.992949] PM: Writing back config space on device 0000:00:0c.2 at offset 1 (was 2b00002, writing 2b00006)
[ 2.057576] pci 0000:00:0f.0: resuming
[ 2.086432] cs5535audio 0000:00:0f.3: resuming
[ 2.116217] PCI: Setting latency timer of device 0000:00:0f.3 to 64
[ 2.152806] ohci_hcd 0000:00:0f.4: resuming
[ 2.189648] PCI: Setting latency timer of device 0000:00:0f.4 to 64
[ 2.254657] ehci_hcd 0000:00:0f.5: resuming
[ 2.292657] PCI: Setting latency timer of device 0000:00:0f.5 to 64
[ 2.326384] usb usb1: root hub lost power or was reset
[ 2.359114] PCI: cache line size of 32 is not supported by device 0000:00:0f.5
[ 2.454342] serial8250 serial8250.0: resuming
[ 2.487035] platform pcspkr: resuming
[ 2.518961] platform vesafb.0: resuming
[ 2.551036] serial8250 serial8250: resuming
[ 2.583619] ov7670 0-0042: resuming
[ 2.615378] usb usb1: resuming
[ 2.802435] hub 1-0:1.0: resuming
[ 2.834185] usb usb2: resuming
[ 2.865527] usb usb2: root hub lost power or was reset
[ 3.875834] psmouse serio1: resuming
[ 3.964956] OLPC-DCON 1-000d: resuming
[ 4.015493] platform dcon: resuming
[ 4.042037] platform olpc-battery.0: resuming
[ 4.069215] olpc-dcon: The CPU has control
[ 4.095072] ac97 0-0:AD1888: resuming
[ 4.119758] Restarting tasks ... done.
[ 4.284375] PM: Preparing system for mem sleep
[ 4.311654] Stopping tasks ... done.
[ 4.338953] ac97 0-0:AD1888: suspend
[ 4.362343] platform olpc-battery.0: suspend
[ 4.386241] platform dcon: suspend
[ 4.408789] OLPC-DCON 1-000d: suspend
[ 4.472102] olpc-dcon: The DCON has control
[ 4.494969] psmouse serio1: suspend
[ 4.516649] atkbd serio0: suspend
[ 4.537641] i8042 i8042: suspend
[ 4.558365] usb8xxx 1-1:1.0: suspend
[ 4.579544] usb 1-1: suspend
[ 4.602908] hub 2-0:1.0: suspend
[ 4.623385] usb usb2: suspend, may wakeup
[ 4.644759] hub 1-0:1.0: suspend
[ 4.665309] usb usb1: suspend, may wakeup
[ 4.687374] ov7670 0-0042: suspend
[ 4.708210] serial8250 serial8250: suspend
[ 4.729800] platform vesafb.0: suspend
[ 4.751049] platform pcspkr: suspend
[ 4.772099] serial8250 serial8250.0: suspend
[ 4.793777] ehci_hcd 0000:00:0f.5: suspend
[ 4.821547] ohci_hcd 0000:00:0f.4: suspend
[ 4.848885] cs5535audio 0000:00:0f.3: suspend
+rUSB setup
Suspend/resume
wp
Init SHA-1 variables

Interacting due to botched resume
ok

Change History (3)

comment:1 Changed 7 years ago by wmb@…

  • Component changed from ofw - open firmware to hardware
  • Owner changed from wmb@… to mlj

This is probably caused by memory going bad while suspended.

comment:2 Changed 7 years ago by wad

  • Resolution set to duplicate
  • Status changed from new to closed

This is a definitely a duplicate of #4449. This laptop was running a version of OFW which compared memory before and after a suspend/resume, and stayed in OFW if a discrepancy was noticed.

comment:3 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

Note: See TracTickets for help on using tickets.