Ticket #4632 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

[firmware] active antenna not detected on boot

Reported by: Quozl Owned by: mbletsas
Priority: blocker Milestone: Update.1
Component: wireless Version: Development build as of this date
Keywords: Cc: jcardona, ronak, wad
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Problem: already plugged-in active antenna is not enumerated by operating system during boot. iwconfig does not show anything except msh0 and eth0.

Impact: very low, this is not an expected use-case. It complicates testing.

Workaround: physically disconnect and reconnect the USB plug of the active antenna. This results in msh1 and eth1 appearing in iwconfig.

Context: active antenna prototypes 0743 0666 and 0743 0652, two B4 systems, with operating system build 625.

Diagnosis: problem reproduced on two units, in either left or right USB sockets, with a warm reboot or cold boot after removing all power sources. lsusb shows the device exists on the bus. dmesg shows two discovery events but they identify eth0.

# lsusb
Bus 001 Device 012: ID 1286:2001  
Bus 001 Device 003: ID 1286:2001  
Bus 001 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  

dmesg to be attached.

Attachments

dmesg.log (43.9 kB) - added by Quozl 7 years ago.
dmesg of laptop b4 quozl-8 boot with active antenna 0743 0666 attached

Change History

Changed 7 years ago by Quozl

dmesg of laptop b4 quozl-8 boot with active antenna 0743 0666 attached

  Changed 7 years ago by jg

  • milestone changed from Never Assigned to Update.1

Hmmm, not all that low: for a school server (as opposed to the laptop), it is the *normal* case, and should work.

  Changed 7 years ago by wad

  • cc jcardona, ronak added
  • owner changed from dilinger to mbletsas
  • component changed from kernel to wireless
  • priority changed from normal to blocker

This definitely sounds like the active antenna is going into repeater mode (as indicated by mbletsas in duplicate ticket #5336).

Unfortunately, the libertas-flash tool written by Dan Williams doesn't work to downgrade the Boot2 firmware. After finding a machine with python-2.4 and changing libertas-flash.py to even begin talking to a WLAN module running v.3109 of the Boot2 code, it still complains that the response from the WLAN module to a command is invalid.

This is a high priority blocker, as we have already been distributing these modules to trial sites. Can Marvell provide us with a tool for downgrading the Boot2 firmware from 3109 to 3107 ?

follow-up: ↓ 4   Changed 7 years ago by wad

  • cc wad added

A longer term solution must also be found and put into place immediately. We do not want to have to upgrade every active antenna being currently built by QMI.

Why does an antenna in repeater mode ignore the USB interface ?

Until a firmware which doesn't ignore the USB interface while in repeater mode can be built and tested, we should at least move to a version of firmware that waits ten minutes (to ENSURE that even slow boots can complete) before going into repeater mode.

in reply to: ↑ 3   Changed 7 years ago by dwmw2

Replying to wad:

Why does an antenna in repeater mode ignore the USB interface ?

It doesn't. You should still be able to issue the CMD_802_11_RESET command to reset it, and then the Boot2 stuff should work. We should be able to add that to libertas-flash.py quite simply.

I've had this working in the driver, but I think it might have involved bypassing the 'device firmware changed' check, because of the bcdDevice change on reset (#5412).

A completely new tool is _absolutely_ not necessary. We should just make libertas-flash.py work.

  Changed 7 years ago by dwmw2

  • summary changed from active antenna not detected on boot to [firmware] active antenna not detected on boot

  Changed 7 years ago by wad

  • status changed from new to closed
  • resolution set to fixed

Both libertas-flash.py and a driver patch by Marvell are available now for downgrading Active Antennas. See http://wiki.laptop.org/go/Active_Antenna_Reprogramming

To fix the problem indicated above, downgrade to Boot2 firmware 3107.

Note: See TracTickets for help on using tickets.