Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4763 closed defect (fixed)

Duplicate mouse events

Reported by: Eben Owned by: bernie
Priority: blocker Milestone: Update.1
Component: kernel Version:
Keywords: touchpad Cc: dilinger, pascal, Eben, gdesmott, bernie, jg, morgs
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

As of 257, it appears that the mouse is sending duplicate events. This is evidenced by the fact that comboboxes will not remain open when clicked, and that a single click in any text area will select an entire word rather than placing the cursor. Benzea confirmed this with Xev.

Attachments (1)

Xorg.0.log (34.1 KB) - added by erikos 7 years ago.
xorg log of a 258 machine

Download all attachments as: .zip

Change History (19)

comment:1 Changed 7 years ago by jg

  • Keywords update.1? removed
  • Milestone changed from Never Assigned to Update.1

comment:2 Changed 7 years ago by marco

It works fine with an USB mouse.

comment:3 Changed 7 years ago by marco

This is also making impossible to activate an access point in the mesh view.

comment:4 Changed 7 years ago by pascal

  • Cc pascal added

And I can confirm that, using a usb mouse, I can connect to the network again.

comment:5 Changed 7 years ago by bernie

I'm travelling and I'm unable to have a look myself.

  • Could anyone please attach output of lshal?
  • Could anyone please attach the changelog for 257?

There were no changes in X packages recently (please double check in my ~/public_rpms). Is there a new kernel? Or hal?

comment:6 Changed 7 years ago by marco

257 changelog is uninteresting, 256 has a new kernel:

--- kernel.i586 2.6.22-20071106.1.olpc.392edb0680e0d8a ---
* Hack around bugs getting dilinger's latest kernels into joyride.

I'm not sure when the problem started but it looks like last X update was before 201 (which the older one still available).

comment:7 Changed 7 years ago by bernie

  • Status changed from new to assigned

I managed to do the lshal on joyride-257 from here: I see a
"psmouse" device that I didn't remember seeing before.

Could anyone confirm that on joyride < 257 it doesn't exist?

I'm still pointing fingers at either hal or kernel, but the
changelog for 257 says only telepathy changed in this build.
Maybe the changelog is incomplete? Or the bug was already
in 256 too?

comment:8 Changed 7 years ago by Eben

257 was the first build in which I saw the problem, but I didn't test every build. It was likely introduced somewhere in the 4 or 5 builds prior.

comment:9 Changed 7 years ago by marco

From 247 to 257 the only related change seem the kernel one I posted above.

comment:10 Changed 7 years ago by dilinger

Prior to 256, random kernels were pulled into joyride; so, we have probably a month or two worth of commits between 255 and 256. Comparing the changelog isn't useful.

However, my suspicion would be this:
http://dev.laptop.org/git?p=olpc-2.6;a=commitdiff;h=a9035d57001f4f97c00c7362fbd2e9a49e15be99

comment:11 Changed 7 years ago by jg

  • Cc Eben added

Eben, please attach your X log file....

comment:12 Changed 7 years ago by gdesmott

  • Cc gdesmott added

comment:13 Changed 7 years ago by jg

  • Cc bernie jg added
  • Component changed from x window system to kernel

andres, please give us a kernel to test ASAP....

Changed 7 years ago by erikos

xorg log of a 258 machine

comment:14 Changed 7 years ago by dilinger

Note the "() OLPC ALPS GlideSensor: Registering 4 buttons." bit. From what I've seen, hal and the kernel look like they have the right number of devices, just the wrong number of buttons..

comment:15 Changed 7 years ago by tomeu

Just in case it is useful, the output of xev:

Click with left button:

ButtonPress event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 223454, (459,529), root:(459,529),
    state 0x0, button 1, same_screen YES

ButtonPress event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 223454, (459,529), root:(459,529),
    state 0x100, button 1, same_screen YES

ButtonRelease event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 223501, (459,529), root:(459,529),
    state 0x100, button 1, same_screen YES

ButtonRelease event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 223501, (459,529), root:(459,529),
    state 0x0, button 1, same_screen YES

and with the right button:

ButtonPress event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 235058, (459,529), root:(459,529),
    state 0x0, button 3, same_screen YES

ButtonPress event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 235058, (459,529), root:(459,529),
    state 0x400, button 3, same_screen YES

ButtonRelease event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 235130, (459,529), root:(459,529),
    state 0x400, button 3, same_screen YES

ButtonRelease event, serial 24, synthetic NO, window 0x1000001,
    root 0x3d, subw 0x0, time 235130, (459,529), root:(459,529),
    state 0x0, button 3, same_screen YES

(in 272)

comment:16 Changed 7 years ago by morgs

  • Cc morgs added

comment:17 Changed 7 years ago by bernie

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in joyride and Update1. Thanks!

comment:18 Changed 7 years ago by mstone

  • Keywords touchpad added
Note: See TracTickets for help on using tickets.